Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Only one motor works on Romi

I’m having an issue with the Romi robot I purchased for use with FRC. Using code that we’ve confirmed to work on another Romi, the motor closest to the 2x20 female GPIO header has never worked. We have verified the motor works on the other side of the robot so it doesn’t appear to be a problem with the motor itself. We’ve swapped out everything we feel could causing the issue including batteries, Raspberry Pi, etc.

Any thoughts on what this might be?

I am sorry you are having problems with your Romi Robot. For clarification, did your items come as part of the #4022 Romi Robot Kit for FIRST or were they purchased separately?

Could you try removing the Raspberry Pi and running the MotorTest.ino example from our Romi 32U4 Arduino Library? Once that example is running, you will need to press the A button to start it; then the robot should cycle through running each motor (one at a time) in both directions.

Brandon

Brandon,

These were part of the #4022 Romi Robot Kit for FIRST. I was able to load the motor test program and the behavior is the same. The left motor drives forward and backward as expected whereas the right motor doesn’t move at all.

Here’s a link to the robot in action, then not in action, then in action again: https://youtu.be/cqEiDzW22D4

Thanks for your help.


Doug

Thank you for the additional information and the video. Could you email us at support@pololu.com with your order information and a reference to this post so we can look into getting you a replacement?

In the meantime, if you are up for further troubleshooting with unit you have, we might still be able to get it working. If you remove the motor on the problematic side and measure the continuity between the MR+ pin of the motor header and the duplicate MR+ pin next to it, that would help rule out a connection issue. You can do the same with the MR- pins. I have indicated which pins I’m referring to in the image below:

You could also try using a multimeter to measure the voltage on these duplicate unpopulated MR+ and MR- pins while the MotorTest program is running to see if you are getting any response from them.

Brandon

Thanks, Brandon. I will send a note to support.

In the meantime, I did as you suggested. (As best I could being a software guy.) There’s continuity between the pins in the header and the respective unpopulated pin. I’m also getting a reading from the unpopulated pin for MR- with the voltage ramping up from 0 to ~5.8 on my multimeter when using the motor test program. However, I’m getting zero on the MR+. Testing the LR (working) side, I get values from both LR+ and LR-, similar to what I see on the MR-.

I certainly appreciate all the help on this!

From that information, it sounds like there might be an issue with the motor driver. We test every unit, so it was probably working at some point, but maybe something as mundane as an electrostatic zap damaged it. Unfortunately, it would not be practical to fix that, so we will just keep an eye out for your email and can follow-up with you there.

Brandon

Hi Brandon, my name is Luis and I have the same problem that describes Doug. I thought the Romi 32u4 card was damage and bought another, but… have de same behaviour with this new one. So I think it’s a FRC firmware or update issue. Did you fix this? Any idea? :frowning:

Hello, Luis.

In a follow-up email you sent us, you mentioned that you were able to get one of the boards working after changing your program, but the other one is still not functional.

if you would like to troubleshoot the non-functional board, can you post more details about what happens when you run your program (and what you expected to happen)? Also, could you post close-up pictures of your board that show all of the solder joints?

Brandon

Brandon. I think the damage on my first pololu card was my fault, becauseI really didn’t take much care of her and when the motor became to fault I unsolder tha conexions and all was a mess. So I decided to bought the new pololu card, and it’s working fine so I hope this one will have a better life. Thank you for you time and your support.

1 Like