Odd servo behavior

I have a Maestro Micro servo driver board and all works fine using a selection of micro servos I have tried.

Problem is, I want to use some bigger servos I have for a robot arm project but they behave in a strange way.
Using the Control Center software, when I move the slider of the channel that the servo is connected to, the
servo moves but there are times in the length of the slide when the servo doesn’t move (mainly at the beginning and
end of the slide) . This makes it impossible to set accurate movements in a sequence.
Sliding with a micro servo (Turnigy TG9), the movement exactly follows the slider’s position.

The bigger servos that have this strange behaviour are new MG 996R and the same happens with some new MG946R
both Tower Pro.

My Maestro board has a seperate 5volt 5amp supply for the servos.

Tried different speed settings and Period settings but can’t get this problem sorted…

Thanks for any help


Hello, Phil.

Can you use a multimeter and measure the actual voltage being supplied to your servos? What kind of load is on your servos while you try to command their positions? Can you upload your Maestro settings file and post a video that clearly shows the behavior you are seeing? It would be most useful if the video showed the servos’ movements and the sliders’ positions in the Maestro Control Center. You can generate a .txt file containing the Maestro’s settings by clicking “File” > “Save settings file…” inside the Maestro Control Center.


Hi Jon… thanks for the response…
The supply to my servos is a regulated 5volts with at least a 5 amp capacity.
This odd behavior happens with just a servo electrically connected with no physical load as well
as when the servo is on my robot arm…

I’m just going through the various servos I have and can confirm that this doesn’t happen with the plastic geared
micro servos I have.
Seems to be just happening with the larger metal geared servos I’m wanting to use.
Tested today and I can move the slider from say 900 to about 1100 before the servo responds…then it moves further
along the slider travel…just seems to be “no response” dead spots for some reason…

Have got a couple of different model larger metal gear servos coming tomorrow.
Will try those and report back…
Have even tried on a different computer.
Been through all the different settings available and nothing I change cures the problem…


Like I mentioned in my reply, if you send a video of the issue and attach your Maestro settings file, I might be able to see if I can notice anything obviously wrong.

Also, if you have a hobby RC transmitter and receiver (or have access to one), you could see if you can reproduce the issue when commanding the same position from those servos.


Hi Jon
Will try to do a video.
Regarding the settings file, I just did a “reset to default settings” and hooked up a servo to channel 1.
So, no fancy settings on my behalf. Speed and acceleration both at zero.

Bit further forward today, I received a Tower Pro MG995 servo this morning and this works perfectly
with no lag between slider movement and servo response.
This is great because I can swap out the robot arm servos for these 995s and get back accuracy in settings for
a sequence.

The ones that have a lag are Tower Pro MG946R and MG996R.
Not sure what the “R” means but it’s a common thing with the laggy servos…

Took note and the lag covers about 110 positions on the slider before the servo reacts…

Anyhow, it’s a servo problem it would seem…


Resetting the Maestro to factory default settings was a good idea; that helped me to check to see if there was anything amiss with the way you configured it. It does sound like the issue you are noticing is unique to those servos. (So, if you were to try using them with a transmitter/receiver, I would expect to see the same behavior.)

Also, note that not all commonly available regulated power supplies output a steady or accurate voltage. So, because 5V is close to the 4.8V bottom end of the operating range of your digital servos, you might double-check with a multimeter that that is what your supply is generating. If you haven’t already, you might also try testing the servos one at a time, too, in case this is a power issue where your supply is not able to provide the current the servo needs at that moment.


Hi Jon
Yes, I tried a higher voltage (6.5V) and that made no difference. Also was testing just using one servo.

Interesting thing that to double prove it, I put the servo on an Arduino and ran the “Servo Knob” example script.
This takes an analog reading from a potentiometer and maps that to the 0-180 that the servo expects.
As expected, there was a lag in response from the servo as I turned the pot.
Also, I bought one of those cheap servo testers with a knob adjust and again I could turn that a few degrees before
the servo responded…

I know next to nothing about servos so I’m curious about this. Wonder if it’s to do with the "dead bandwidth"
of these particular servos…maybe not

Anyhow, using the Tower Pro MG995 servos, I have got my 3D printed robot arm working well with your excellent
Maestro board. It’s this design http://www.thingiverse.com/thing:1454048

So, no more Tower Pro MG946R or MG996R servos for my future projects…

Thanks for sticking with me through this Jon, much appreciated