Not receiving valid model id from VL53L1X always

I am developing a application that is communicating with VL53L1X using I2C. My problem is, while checking model ID of VL53L1X sometimes i am getting valid model ID ‘0xEA’ sometimes i am getting 0x00.
Following are the things i tried to solve this problem,
1.I tried to lower the frequency to 100kHz and higher the frequency to 400kHz, which doesn’t seem to make a difference.
2. I changed the values of addresses 0x2e and 0x2f from 0 to 1, because my GPIO and I2C pins are
pulled to +3.3V.
Configurations are default settings only.
This problem is not allowing me to do further development in my project.
can anyone help me to fix my problem?

Thanks and Regards
Devika Raju

Hello, Devika.

Can you post pictures clearly showing your setup and how everything is connected? Also, can you post your entire code?

- Amanda

Thank you for your reply.
I am attaching the snippet of initialization of VL53L1X

I cannot help you troubleshoot the problem without knowing more about your system (e.g. what microcontroller are you using to read the sensor). Please provide more details about your setup (e.g. other devices and connections) and pictures like I requested in my previous post or at least a wiring diagram.

- Amanda