No power to Zumo 32U4

Blue lights won’t come on. No power to motors. Can still upload code. LED’s working.
Any ideas on how to solve power issue. Batteries are good.


I am sorry to hear you are having trouble with your Zumo. Could you let me know what kind of batteries you are using and post some pictures of your Zumo that show the battery terminals as well as the soldered connections between the battery terminals and the main control board? Also, can you use a multimeter to measure the voltage of the VB and VBAT pins with the batteries installed and the power switch in the on position? I added a blue box indicating those pins on the pinout diagram below.

- Patrick

Hi Patrick
So batteries are new Energizer brand and are working well in another device. VBAT/GND reading was 0.00, VB/GND reading started around 6 dropping to around 4.5. Terminals are hard to see but are also showing a reading.
Hoping you can help?

It looks like the Zumo’s power switch is in the off position in your pictures; can you double check that the behavior is the same with the switch turned on?

Additionally, even though your batteries are working in another device the behavior you see when measuring between VB and GND is not reassuring. Do you have any other batteries (ideally new fully charged ones) that you can try?

- Patrick

Uploading: IMG_3126.HEIC…

They are new batteries. I have taken them out and replaced with another set and attached photos in the ‘on’ position. I had tried and had identical results in the ‘on’ or ‘off’ position - made no difference.

I suspect something might be shorted on your Zumo, so please avoid installing batteries in your Zumo for now. Have the Zumo’s blue power LEDs ever turned on, or has it always behaved this way?

I also just noticed that it looks like you had your multimeter set in a current measuring mode instead of DC voltage measuring mode.

For now, can you try setting your multimeter to resistance mode and measuring between the same pairs of pins (VB and GND then VBAT and GND) with the batteries removed? Please try that with the switch in the on and off positions in case that makes any difference in the readings.

- Patrick

After thinking about it some more, I suspect the short circuit I was concerned about earlier was most likely caused by your multimeter being in the wrong mode. (In case you are not aware, when a multimeter is used in current measuring mode, it acts as a short and should typically be connected in series with a circuit. By connecting it in parallel with the batteries like you did, you were momentarily creating a short circuit directly across the battery voltage.) Please make sure to set your meter to the correct mode and plug the red lead into the right socket before doing any more measurements.

It would still be a good idea to check the resistances on the Zumo I mentioned to see if they look unusual (they should normally measure several megaohms). If that looks okay, could you put the batteries back in and repeat your earlier voltage measurements properly?

- Patrick

Hi Patrick
You’ll need to be more explicit- exactly where should the leads be plugged in and what should the dial point to to measure DC voltage. I know very little about electronics.
I can’t tell you if the blue led’s have ever come on because I had not personally tested this machine until a student was trying to upload move forward code. Up until then we’d only worked with the led’s to learn coding.

Knowing how to use a multimeter is a fundamental skill for working with electronics, so I strongly recommend that you learn how your multimeter works and find some ways to practice and get comfortable using it. It might be a good topic for your students to learn about as well.

You can find a ton of guides and tutorials for how to use a multimeter in a quick internet search. Here is a link to a tutorial I found by Sparkfun that includes both a quick video overview and more detailed written information.

- Patrick

All readings are 0 on the voltage DC measurement, without batteries. Batteries in and pwr off VB = 5.91, VBAT = 0 pwr on or off. Batteries are at 1.47V.
Do I need to send it back to the supplier.
In 1x 50minute lesson on coding to 150 11/12 year olds per week I have no time to teach electronics. I expect the device to work, if it’s not I need to repair it or have it replaced. Please help.

We test every unit we make, so your Zumo was probably working at some point, but it is possible this one has been damaged. Please note that these robots are not appropriate for 11-12 year olds unless they have supervision from an adult who understands electronics and programming.

If you got it from us, please email us with your order information and a reference to this thread. If you got it from somewhere else, any resolution would need to be between you and them.

- Patrick