No device is recognized when I plug into Balboa


When I plug USB into my Balboa, I see the power LED turn on and LED 13 start to slowly blink. However, on Windows, no device shows up at all in device manager. I tried this with my laptop and had the same result.


Since your Balboa is not recognized on two different computers, my first suspicion is that your USB cable is not capable of data transfer. Some cables like those that come with chargers are not fully USB compatible. Can you try a different USB cable? The ones we carry like this one would work, or you can probably find a cable like that at just about any electronics store.


D’oh. I did actually try two cables but neglected to check if either were data cables. After finding a data cable it worked fine. Sorry about that!

Gah! I’ve been messing with my Balboa all day and couldn’t figure out why it wouldn’t work. It just worked a couple weeks ago! Reinstalled drivers and reading thought the forums all day. Turns out I grabbed the USB cord used to charge my bicycle light instead of my data cable.

So, for peeps out there that can’t get their boards to be recognized in Device Manager, make sure you have a Data Cable!