Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Newb trying to run Simple-Test on USB AVR 2.1: "orangutan.h No such file..." error

Hi all. Total beginner here taking first baby steps with a Pololu USB AVR programmer 2.1 and Baby Orangutan B-328 controller.
I’ve been going through the various install processes and I believe I have installed things correctly (grab attached). I’ve got the Programmer V2 config utility running (shows “connected”), and I’ve installed the CrossPack AVR for running on my Mac. I can run avr-gcc -v, make -v, and avrdude -v and all seem to show correct installation. I then try to run the Simple-Test in libpololu-avr/examples/atmegaXXX/simple-test/ but I get the following error:
fatal error: pololu/orangutan.h: No such file or directory
#include <pololu/orangutan.h>

What I can’t figure out is that I can see the orangutan.h file in libpololu-avr/pololu (grab attached). libpololu-avr is just on my desktop. Does this need to be located somewhere else? Or is there something else going on? Sorry if this is a super-basic or obvious. Thanks for any assistance.

Hello.

Thank you for posting all that information.

It sounds like you might have not installed the AVR library. If so, please follow the instructions under the “Installing the Pololu AVR C/C++ Library in Mac OS X” section in the Pololu AVR Programming Quick Start Guide and let us know the results.

- Amanda

HI AmandaS.
Thanks for your assistance! I navigated in terminal to the libpololu-avr folder and then ran the “sudo make install” command. I’ve attached the results. I’m not sure what to make of the “No rule to make target…” response. Have I done it correctly?

AmandaS - I tried to run the “simple test” again (after doing the sudo make install) and it looks like I’m still getting the same error. Screen grab attached.

It looks like you’re missing several files in your libpololu-avr folder, including libpololu_atmega324p.a. Can you download the latest .zip file for the Pololu AVR C/C++ Library, which is linked in the “Download Instructions” section under “ZIP files” in the Pololu AVR C/C++ Library User’s Guide and follow the instructions from my previous post?

- Amanda

Hi Amanda:
Strangely I’m seeing that I have that “libpololu_atmega324p.a.”. I’ve attached a screen grab showing the location (shown at bottom of grab). The libpololu-avr folder is on my desktop - do I need to move that somewhere else so the programmer can “see” those files? If you think I actually do need to download the latest .zip files again let me know and I can do so, but it does appear I have those files so I’m confused.

The file highlighted in your screenshot is libpololu_atmega328p.a, not libpololu_atmega324p.a. Please download and install the AVR C/C++ Library.

- Amanda

Amanda -
Duh! My bad! I re-downloaded the AVR C/C++ library and now have that file. Then I went through the “simple-test” process and I think we’re getting somewhere! I believe I’ve loaded the simple-test program to the Baby Orangutan (grab attached). The only minor thing is that Step 5.4 says “If you are using a Baby Orangutan, you will just see the red user LED blink.” But, the red LED on my baby orangutan just comes on and stays on. Is that ok? If so, I guess I’m ready to start loading other programs. Thanks so much for your continued help.

The simple-test example toggles the red LED, so you should be seeing that behavior on your Baby Orangutan B-328. Your AVRDUDE command is programming for the ATmega324P and not for the ATmega328P used on your Baby Orangutan. You should navigate to libpololu-avr/examples/atmega328p/simple-test and run the Makefile there.

- Amanda