Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

.net framework 3.5 Installation

#1

I’m trying to install the Maestro Control Panel which requires .net framework 3.5. Yesterday I did a clean install of Windows 10, however when Maestro Control points me to installing 3.5 the message “The following feature couldn’t be installed: .NET Framework 3.5 (includes .Net 2.0 and 3.0)”. The error code is 0x800F081F. No matter what I try I keep getting the message.

Tried:
Using Windows Features
Downloaded the file dotNetFx35setup.exe

Before the clean install, the Maestro Control Panel worked fine. Any help would be appreciated.

Chuck

#2

Hello, Chuck.

I am sorry you are having trouble installing the Maestro software on your PC. Were you able to get the Maestro installer to finish after it showed the error message? If so, can you try running the Maestro software and let us know the results?

You mentioned downloading the installer for Microsoft .NET Framework 3.5. Did you try running that executable? If so, did anything happen during the installation (e.g. error message)?

- Amanda

#3

Admanda,

Thanks for the reply. I finally got .NET Framework 3.5 installed and the Maestro software. It required adding a new line to the Windows 10 Registry. I’m able to operate a servo. My next task is to try running it in Arduino. If I have problems do that, can I contact you direct or should I go to the forum?

Chuck

#4

That’s great! I’m glad you got your issue resolved; thanks for letting us know how you fixed it.

We recommend posting on the forum, especially for code-related issues, which allows others to participate in and benefit from the discussion.

By the way, in case you did not already know, you can use our Arduino library for the Maestro to help you get started in your next task.

- Amanda

#5

Hi,
As we know that, “.net framework 3.5 error 0x800f081f” was issue of over 1 year ago and experts has already given some recommended solution to fix this issue. However, many users have still this problem on their PC and they are asking for better solution.
If you are regular user of Windows 10 Operating System and you are getting .net Framework 3.5 error 0x800f081f in Windows 10 continuously, then you need to fix this issue immediately.
Procedure: You need to configure Group Policy to fix error 0x800f081f Windows 10 update 1709
Step 1: Press “Windows + R” key from keyboard and type “ gpedit.msc ” and press “enter” key
Step 2: Group Policy Editor Windows appears, and then go to computer Configuration > Administrative Templates >System
Step 3: Now, double click on Specify settings for optional component installation and component repair from right-hand panel
Step 4: Mark the checkbox next to Enabled and click on Ok . Please check if the problem is resolved
For more information, you can read the article:[How to Fix .net framework 3.5 error 0x800f081f in Windows 10