Need help with micro servo controller


I have just received my Pololu micro servo controller. I gave it a try, sending out command 4. And this thing just starts flashing green with red LED on. I have removed the jumper and the controller should be set at Pololu mode. According to the manual, this pattern of LED flashing means the baud rate is too high, but I have set my serial communication at 9600 of baud rate… I tried even lower baud rate and it still flashes green with red on. Any idea?

I tried the windows program and see how Pololu and servo respond. Pololu seems to receive fine. But my servo will only tick 2 steps and stop no matter what I am sending. Any ideas? Thanks.

Can you describe your setup in detail, like what is connected to what, how are you powering the servos and the servo controller, and what do you mean by a “step”? Can you move the servos to two positions but not a third, or does the servo just twitch a little then stop?


I am using the Pololu Serial Transmitter utility for Windows program to send out commands to Pololu. The connection is the following:

So for the power, I am using a 6 pack battery, rated at 7.2V and 600mAh (it came from the RC airplane package)
The battery is connected to a 5V regulator which is used to power the Pololu chip, and the SP232 TTL to RS232 driver, and the servo itself (all connected to the 5V output from the regulator)

  1. the jumper is removed to set the module in Pololu mode
  2. no power is connected to the upper right corner of the module
    (I think I saw something weird when i hooked the upper right corner with the source output from the 5V regulator. I measured the voltage at the + - nodes of the battery and it says 0. But when i remove that connection, the battery is back to 7.6 to 8V)
  3. the signal pin is connected to the servo and the servo is powered directly with source output from a 5V regulator
  4. the logic serial port input is connected to a SP232 driver, for receiving data from the computer
  5. the Pololu chip is powered by the same 5V regulator

So I could send the commands through RS232 to Pololu fine (flashed green LED and yellow LED came on after transmission). The servo just twitched two times, moving in clockwise direction with 2 step-like movements).

The servo I am using is the GWS MINI STD.


Your regulator might not be able to handle powering a servo. Are you sure it can? The micro servo controller has its own regulator on board, so if you’re starting with 7.2V, I recommend connecting that to the unregulated power input of the servo controller. The servo controller can also receive RS-232 serial; why are you using the RS-232 adapter? By the way, we also have the servo controller with the level converter and DB9 connector built in.

- Jan

What would happen if I don’t get enough current supply to my servo?

It wouldn’t work, and they way it wouldn’t work would depend on all sorts of things. It could fail exactly the way you’re describing. Do you have a reason to expect your regulator to handle the load?

- Jan

I see. I think that the other posts have mentioned about problems caused by power related issues.

Thanks for the advice, I purchased a really small servo, and it works with the pulse widths I fed in.

Now I am still not too sure about the idea of plugging in the battery straight to the “servo power” pins of the Pololu module until I can confirm the following:

Does the module regulate power connected to the “servo power” pins and turn it into 5V regulated voltage? I used a meter to measure the resistance between the servo power pin + and the servo 0 pin + and there seems like nothing is in between them. I know the VIN source will be regulated so the logic component has some protection to it. Is that what you are referring to?

Also, a question about the serial communication. The commands eventually will be sent by the PIC18F micro that I am using. And I have tried to do that but it always flashes Green LED with the Red ON as well. This indicates too high of baud rate according to the manual. But that’s weird… I thought the Pololu mode is supposed to detect the baud rate from the first byte (I am only using 4.8k br). So it could be that the first byte is faulty and I will have to reset the transmission. Now do I simply control the reset pin by pulling it HIGH then LOW to achieve this?

Thanks in advance.

The servo power pins are connected only to the headers for the servo connection (except for ground, which is connected to the rest of the board). In many applications, servo power and logic power is separate. If you are using the same source, you can connect it both to the servo power and to the controller power pins.

The reset line is active low, so you should normally let it be high, and pull the line low to reset.

- Jan