Need help regarding pololu mp3i

There is no supply voltage been shown when I try to read the voltage drawn from the robot. I have installed Atmel studio 6.1 and I am using Pololu USB programmer for my mp3i pololu robot. I previously got an error saying ‘target voltage to high and not in the range of device operation’. Looking at the other forums, I changed the Maximum and Minimum limits and also the frequency cycle on utility configuration. It still shows the same error. I then tried reading the voltage been drawn from the robot using the help and recommendations from other forums. There was no value and it gave 0.0V. Is it to do something with the connection?


I suspect you might not have the jumper that connects the battery voltage to ADC6 on. You can refer to the picture below to see where that jumper goes.

If you do have the jumper in place and still have problems reading the battery voltage, could you tell me more about your m3pi? Do you have other components connected to the robot? Could you post your modified code and pictures of your robot?

- Jeremy

Yes, all the jumpers are in place and I have USB pololu programmer connected to the robot . I am using the sample code provided by atmel 6.1 to get started. Do you know how can I upload the images? I tried to but it says file invalid.

Which sample code do you have loaded onto your 3pi? Could you post the entire code here using the code tags? In your first post, you mentioned that you got an error saying that the target voltage was too high. Could you post a screen shot of that error? Could you also post a screen shot of the message that appears in the Pololu USB AVR Programmer Configuration Utility?

You can upload pictures under the “Upload attachment” tab when posting a reply. If you continue to have problems uploading the pictures, you could try uploading them on image-hosting sites like Photobucket or ImageShack and then use the “IMG” tags to post them.

- Jeremy

Here is the code I am using. I have also attached the images.

/* 3pi_app1 - an application for the Pololu 3pi Robot
 * This application uses the Pololu AVR C/C++ Library.  For help, see:
 * -User's guide:
 * -Command reference:
 * Created: 12/4/2014 4:44:00 AM
 *  Author: vishnu

#include <pololu/3pi.h>

int main()
	play_from_program_space(PSTR(">g32>>c32"));  // Play welcoming notes.

		// Print battery voltage (in mV) on the LCD.

		red_led(1);     // Turn on the red LED.
		delay_ms(200);  // Wait for 200 ms.

		red_led(0);     // Turn off the red LED.
		delay_ms(200);  // Wait for 200 ms.

Thank you for all the photos. It looks like the 3pi is working fine. Could you try measuring across the VDD and GND pins on the bottom side of the AVR programmer while the 3pi is on to see if the 3pi is outputting 5V? If you do measure 5V but the computer still says the target voltage is low, I suspect the AVR programmer is damaged.

- Jeremy

I tried measuring the AVR’s VDD and the ground and it does not show any output. I also tried checking if there was any output from the 3pi itself where the wire connects the 3pi to AVR programmer. there was no output. Could it be that my 3pi is damaged or blown? if so, what do i do next?

If the VCC pin is not outputting anything when the 3pi is on, the 5V regulator or a trace on the 3pi might have been damaged. Since the 3pi still turns on and displays things on the LCD screen, I suspect the 5V regulator is working. If you have a multimeter with a continuity feature, could you verify that there is continuity between the VCC pin on the ISP header and the VCC pins towards the front of the 3pi?

- Jeremy

Hello jeremy,
This is the error i am getting while programming. May i know what could be wrong? In previous forums, i read there could be a damage in oscillator and would need to replace 3pi? is it so?
thank you.

This is a different error than the one you received before. Did something in your setup change? What was the target voltage shown by Atmel Studio when you got this error? In my previous post, I asked if you could measure continuity between some VCC pins. Did you do this?

- Jeremy

Yes, I have checked the continuity. There is a disruption in the circuit so I am connecting the USB AVR programmer directly to the ISP header and not using the above extra head bit. I am attaching the image so you can see it even clearer.

This is the error i am getting while programming.

This is a problem in continuity with the extra head bit of the robot so I attached the USB AVR programmer directly to the ISP header.

Also on clicking read voltage 4.6V in atmel, it shows getting voltage…ok.

Are you clicking the “Set” button in the Device Programming menu after changing the ISP Clock frequency? The exclamation mark on the button should go away after the frequency has been set. Could you try programming the board again after setting the frequency? Could you also post pictures of the underside of the m3pi expansion board? Were you ever able to program your 3pi or anything else with that programmer?

- Jeremy
This is how I am trying to program using the 6 pin AVR programmer(not attached in the pic ). Its shows the error device signature not found. is it to do something with device signature? target voltage seems fine and the program is trying to upload on the target device just when the error appear device signature not found.

and also i have clicked on the flag which is now disappeared but the error remains.

This is how I am trying to program using the AVR programmer (not seen in the pic). It shows error that device signature not found after clicking the flag as you said in the previous post. is it to do something with device signature as it does not show up.
target voltage seems fine as the program is being sent to the target device but just then the error appears device signature not found.

The picture does not show how you are using the AVR programmer. In my previous post, I asked you to post a picture of the underside of the m3pi expansion board. Could you post this picture along with a picture of how you are connecting the AVR programmer to the 3pi? You also did not answer these questions from my previous response:

- Jeremy

And yes I did click on the set button after changing the ISP clock frequency. I also tried programming different frequencies. Just to try. It showed the same error. I haven’t been able to program using the programmer even before.

Thank you for posting the pictures. It looks like you are using the thin USB cable supplied with the programmer. Could you try a different USB cable to see if the cable might be the problem? Could you also try using a different USB port and a different computer?

- Jeremy