Need help programing Baby Orangutan B with USBtiny

I’m trying to run the sample program mentioned in the orangutan user guide (BlinkLED). I’m getting the following results:

  1. Unmodified makefile
  1. There is no /dev/ttyUSB0, and in general the USBtiny doesn’t show up under /dev at all. So I change the command line in the make file to remove the -P option and get

Now, /dev/ttyS0 is my serial console, which I’m using to talk to my Ubuntu box, so that wouldn’t be expected to work, but it is the default in /usr/local/avr/etc/avrdude.conf.

In general, the programmer doesn’t create or attach to any device nodes that I’m aware of. Running udevadm shows me that it attaches to the /devices/pci0000:00/0000:00:1d.3/usb5/5-2/5-2:1.0 (usb) node when it’s plugged in. udevadm info --attribute-walk shows that as

I’m not a udev adept, does anyone here see what I should be using for an interface device with this?




That Makefile was not designed for your programmer, so you will need to edit it before running “make”. Is this the programmer you are trying to get help with? You should really be asking the manufacturer of that device for help instead of us, but it looks like you need to run avrdude with the “-c usbtiny” option.

Good luck!


Yes, I did modify the makefile to use usbtiny, I should have mentioned that, sorry.

I realize the canonical place to ask questions about this would be there, but they’ve been less than helpful to this point, and I thought someone else here might be using that programmer.

As it turns out, it does work on a previous version of Ubuntu, so maybe there’s a problem in the new version or something. I’ll work that out.

Sorry for the bother.


The errors you posted before were due to the fact that the Makefile was not modified. Does that mean that it works now, or are there still problems? Could you post what works or at least an updated error message so that if anyone comes to this page with the same problem they can get some help?


you might want to try “/dev/ttyACM0” as the device…

check by listing “ls -l /dev/ttyACM*” if its there when you plug the device in… if that doesnt work, check your /var/log/messages when you plug the device in…

“tail -f /var/log/messages” will show what device is configured when plugged in…

Yes, sorry again. I modified it after I copied that output (too much or not enough editing when I replied).

I don’t have my other ubuntu box handy at the moment, but here’s the current output from make on the new version of ubuntu.

However, lsusb shows this vendor/product id after the device is plugged in (see below).

Nope, no ttyACM under /dev

Nothing shows up under /dev though.

The vendor/product id that avrdude is looking for is, in fact, there however:

The avrdude documentation says that I can specify the port as “usb” in /etc/avrdude.conf, which I did, but no luck. However, on my other ubuntu box I did the same thing and it does work there, which leads me to wonder if there’s a kernel change between the two or something.


Ah, so it does work on another computer with a different version of Ubuntu? That is a big clue that you are doing everything right. Anyway, I do not expect that /dev/ttyACM0 or /dev/ttyUSB0 will have anything to do with it, but the manufacturer of your programmer should be able to help you with that.

By the way, you never did say which usbtiny-based AVR programmer you are using - I know of at least three different things it could be.

Good luck, and please let us know if you get it working.

It’s the one from Adafuit ( … ucts_id=46)

I’d be interested in what you think it could be. I’m going to reinstall ubuntu on the box that’s not working and try it again.



Oh, what I meant was that I did not know whether you have the Adafruit one, the Sparkfun one, or some custom one, not that I had any idea about the problem. I have never tried a usbtiny programmer, and our USB AVR Programmer works - as far as I know - with all recent versions of linux.


hi joe,

we reviewed the forums and do not see any post from you requesting help, if you’re having issues with an adafruit product please post in our forums so we can best assist you, thanks!

adafruit support