Need help getting Maestro started

I’ve very close…

I have a Micro Maestro, connected to Maestro control center via USB and it seems to be communicating. The yellow LED blinks about once per second with no servos enabled in Control Center and double-flashes at once per second when a servo is enabled in the software.

I have the servo power coming from a 4 AA battery pack, which measures 6.2V at the rails on the board with brand new batteries, with just the USB and power plugged in.

When I plug in a servo, it never moves. Not from control center, and not the normal “glitches” they seem to have when applying power.

I have tried all the different options under serial control.

I have tried three different servos - 2 standard size Futabas and a micro hitec HS-55, none of them make a peep.

I noticed that when I plug in any of the servos, the servo rail voltage (measured at unused + and - pins) drops from 6V to 1V. It is not drawing any current from the battery pack though.

Any ideas? Is that voltage right?

1 Like

Hi -

I am trying to control a servo using the micro maestro. I’m using the Maestro Control Center for testing.

The board is connected to my windows 7 (64) PC via USB. The servo power is from a 4x1.5v alkaline pack showing 6.2V on the servo power rails.

The board lights up and appears to be communicating. The Maestro Control Center finds the board and connects to it. The yellow LED flashes once a second when connected, and twice a second when at least one servo is enabled.

I don’t get any movement at all from the servos. Not even the “jumpiness” I usually associate with turning them on or off. I have tried all 4 different serial configurations. I have tried with three different servos. Two full size Futabas and a micro size Hitec (HS-55).

One thing I noticed was that the 6.2V on the servo rails drops to 1V as soon as any servo is plugged in. However there is no current flowing from the battery. Does that sound right?

Other than that I have no idea why they aren’t moving. Any suggestions on where to look would be appreciated.



I am sorry you are having trouble controlling your servos. When you mention the supply voltage dropping like that, it sounds like there might be a short somewhere. Can you verify that each of your servos is working by controlling them directly from an RC receiver? Can you explain how you were measuring the current draw from the battery? Can you also post pictures that show how you are connecting everything (including your multimeter)?


Solved (Probably)

It looks like a power supply problem. I got out the old RC transmitter and receiver and had the same problem there.

I noticed that shorting the 4xAA battery pack showed 0A of current.

I connected a 12V SLA battery to the servo power and they started moving right away. I only kept the 12V connected briefly since they are not rated for that, but clearly that was the problem. I’ll find a new battery pack or 6V battery or other source and I expect it will all be good.

Thanks for the help.