Need Help CH Robotics UM6 doesn't transmit data

Hi guys,
I’m working on an project for my university of applied science. I have to get the position of an excavator. For this task I want to place an UM6 (UM6-r2) ( at the upper structure of the excavator.

Unfortunately I doesn’t get any measurement data from the UM6.
I use:
Laptop (windows 8.1)
CH Robotics Interface v3.0.5
USB to Serial adapter (Keyspan USA-19HS (recommended from CH Robotics))
Serial Expansion Board from CH Robotics (

At first I tried to use the Laptop, so I installed the software of the USB to Serial converter and the UM6 Serial Interface (V.2_2_0). After Connecting the Sensor with the Laptop I was unable to get a connection, so I flashed a new firmware (UM2B). With the new firmware I was able to connect the Sensor without any error messages. I tried to plot the three processed accelerations as shown in the getting started UM6 pdf. But I cant receive any measurements of the UM6. The graph shows a straight line with the constant value of 0. (Picture 1)
The read command in the Configuration Tab seems to work poperly. If I change for example the Broadcast Rate to „50“ and click the RAM Commit button happens nothing. If I click the FLASH Commit butten the Messages (Picture 2)
Error: Timeout while communicating with Sensor
Command completed: Write to Flash
Command completed: Write to Flash
are displayed.
While working with the UM6 the PWR LED and the RX LED are continuously shining. The TX LED doesn’t shine. Only if I click the get Firmware button the TX Led is flashing once.
After this problems I tried to connect the UM6 to the serial Port of a Windows 7 Computer. (CH Robotics Interface v.3.0.5) The System hast the same Problems as with the Laptop.

My next step was to change the firmware versions of the UM6. The version UM1A, UM2A, UM2B and UM2C can’t solve my Problem.
Reading the Configuration setting works properly, but the RAM Commit leads to an error message. The comunication window at the bottom side of the serial interface says “Successfully wrote to UM6_COMMUNICATION register.“
The Error Message is shown in picture 4. The German Header means something like:” untreated expection in the application. “Weiter” (next) to ignore the error and continuing the application. If you click “Beenden” (end) the application will be closed immediately”

If I click the FLASH Commit button the message “Command complete: Write To Flash” appears twice, or the error message “Error: Timeout while communicating with sensor.” is displayed. (picture 5)

If I connect the Pololu Serial Transmitter V1.3 to the UM6 and connect it receives data, but I can’t control it seems to be crashed (picture 6) (the UM6 should send the data 20 times per second

You can find all pictures in my dropbox

I hope you can help me to get the UM6 running
Thanks a lot and Greets from Germany


It is unclear what your problem might be. However, you mentioned that you tried changing the firmware version. I believe the UM6 r2 requires firmware revision UM3A to function properly. You should contact the manufacturer, CH Robotics, directly for that version of the firmware and additional assistance.

- Jeremy