My Pololu A-Star Mini LV has died!

Part way uploading the Graphics Test example from the U8g2 library from the Arduino IDE 1.8.19 it stopped.

Now its port does not appear in the Port dropdown of the Tools tab. I am using Board Arduino Leonardo.

The A-Star Mini LV has attached a 4x4 keypad and an OLED graphics display with SSD1309 controller. I am using SPI (CS=10,DC=11,RST=12).

The 5V is still good.

I have tried:

Disconnecting the display,

Re-inserting the USB cable

Pressing the reset button for 15 seconds.

Re-loading the IDE

Re-booting the computer (An Apple Mini).

Is there a solution?

Why did this happen?

How can it be avoided,?

I have had this happen with other microcontrollers using th 32u4.

Thanks John


With the board connected to USB, and nothing else connected to it, could you try pressing the “RESET” button twice quickly (within 750ms) to try to put it in bootloader mode? You will know if it successfully entered bootloader mode if the yellow LED labeled LED 13 fades in and out. If you are able to get it into bootloader mode, could you try following the instructions in the “Reviving an unresponsive A-Star” section of the A-Star 32U4 user’s guide? (There are various methods described there, I generally recommend going through them in order if the first one does not work.)


I thank you for your kind and targeted help. It has got worse, I have also killed a UNO and a Teensy 3.5 (ugh!). The common culprit seems to be u8glib.h for the SSD1309 controller. I actually got the display to work with the Teensy, but it too stopped after a few uploads, I have tried to follow your advice but they all depend on a connection between the computer and the USB port on the microcontroller, but this ha disappeared from the port list and /dev/tty*. Even after reboots. Even the Teensy boot loader app’s port has gone, but not its window.
The cables and computer ports work ok with all other devices.
Please advise, John

It has got worse. I put in a new A-Star mini LV and since I suspected u8glib to be the problem I looked for an alternative. I could not find another library for the SSD1309 so I settled for Adafruit_SSD1306. I compiled and uploaded ssd1306_128x64_spi.ino.
I am using board leonardo since although I have added the Pololu URL to Arduino, your boards do not show up. (
I shows the Adafruit logo, blanks and repeats. I presume it is self-resetting.
After that its port has also disappeared. Quick double-resetting does put the A-Star into boot mode-the yellow LED blinks, but the upload just looks for a port. re-loadind Arduino and re-booting the computer does not help. Please help me.


Sorry for the late reply; I’m not sure why u8glib.h would be giving you those troubles, but since some problems are still occurring with the Adafruit SSD1306 library, I suspect it might be a separate issue, possibly related to your connections or other devices involved.

In your latest setup, how are you powering the A-Star and OLED display? It sounds like the controller is browning out and resetting. If you disconnect the A-Star from the rest of your system and just plug it into USB, does the port show up again? If not, I recommend focusing on getting that board functioning by itself again before trying to troubleshoot anything else involved with your system too thoroughly.

For the issue with the A-Star boards not showing up in your Arduino IDE, it looks like something might have happened to your URL. It should just be

It’s not clear which of the reviving methods you tried, but it sounds like you can get it into bootloader mode successfully and just need to follow the instructions carefully to get the Arduino IDE to pick up on it (which depends on which method you’re using). I typically find the “uploading-before-bootloader method” easiest, but please note that it does not work on Arduino IDE versions 2.x or later. If you continue having troubles reviving it, can you post details about the steps you’re taking and where it diverges from the instructions?


I’m sorry to have bothered you since I now suspect that my hub is respnsible for my missing port problem,
It is the only common factor, having tried multiple chip types, libraries, both Arduino and Teensyuino, and USB cables.
The chips do not show up on a PC either.
It is labelled i5create and it does not have an external power supply.
Is there a way to test it?

We do not make any USB hubs and I do not have any specific advice for testing them. Do the devices show up correctly if you connect them directly to your computer instead of through your hub?

I’m not sure how you came to the conclusion that your hub was the problem, but if you connected all of your devices to the same system, there are many other common factors. For example, you could have a connection issue or short in your system somewhere or it could be pulling too much current from the controller’s regulated supply or USB supply causing brownouts.