Missing .elf file

I am wondering how to build an .elf file. We have been trying to programming the motors,meledy and the leds togeather but we keep on getting an error that says we are missing the elf file.

The .elf file contains debugging information about your project in AVR studio, you shouldn’t have to make one yourself. I would suggest starting a new project (using either the menu project->new project or project->project wizzard) and copy/pasting your existing code into the new file it creates for you.

Did this do it?


yes but the problem is whenever i always create a new file from wizard, after including all the files to the project making sure everything is on the folder and added to the project, whenever i build it, it keeps asking for the .elf files. I even tried to write a simple program that always work to see if it will build but all of a sudden im having error with the .elf files. I was thinking that maybe theres a problem to the program. I will try to reinstall and do try it again. Thanks a lot for the help.

Make sure you are using the most recent versions of WinAVR and AVR Studio. I suggest you reinstall both. I also suggest you try googling the exact error message that AVR Studio is giving you to see if you can find more information about it.

- Ben

yes i do have the latest version of both programs WinAVR and AVR Studio. I just tried to install both programs on my other computer, install the OX2 current drivers, and it works. Thank you for the help and im learning more about this AVR stuff.