minIMU-9 v3 acceleration reading problem

Hi there,

I am having trouble getting the acceleration readings from the accelerometer. I am using the LSM303 library listed on the polulu page for MinIMU-9 v3. I’m running the Arduino “Serial” example, and for some reason the acceleration values in all directions are -32760.


I am able to get the gyro and magnetometer readings fine, so I am sure the wiring is okay. It seems the accelerometer reading does not respond to shaking the sensor. Also, having the sensor fixed on the table, I would expect to have the x and y readings to be zero while the z reading should be about -1g with some error, but that doesn’t seem to be the case. I would appreciate any help I can get.

Thank you.

Hello, Ali,

I am sorry you are getting strange readings like that from the accelerometer on your MinIMU. It sounds like the accelerometer is in a bad state, which can happen when the voltage on the 3.3 V power supply line falls significantly, but is not allowed to drop completely to 0V. We have written a FAQ about this issue, which includes recommendations for how to address it. Can you try taking the measures in that FAQ and see if that solves the issue?


Thank you for your quick reply Jon.

I am using the MinIMU with an Arduino UNO, so I am connecting power to the 5V pin on the MinIMU as the library suggests. Would this still apply?

I just tried the FAQ suggestions in both the 3.3V and the 5V pins and it doesn’t seem to work. Is there anything else I could try? Could it be that the sensor is faulty?

Yes, the FAQ should still apply. The voltage supplied to the VIN pin (in your case, 5V from your UNO) is stepped down through an onboard regulator to 3.3V to be supplied to the L3GD20H and LSM303D.

It sounds like you tried adding a bleeder resistor. What value resistor did you use? Can you post pictures that show how you added the resistor and the rest of your connections?