Micro Maestro servo speed playing up

Hi,

I’m a little new to the micro maestro, but been going pretty well with it so far.

I’ve gotten my simple script to work, and everything was looking perfect! until I un-plugged the micro maestro from my computer, and ran it independently. everything turned on, and moved. but the servos refuse to move at anything other than full speed.
Much fiddling with the Control centre, trying to add ‘speed’ settings into the script, and nothing changes it, the speeds respond correctly whilst hooked up to the computer, but once its free… FULL SPEED only.

As this is a cosplay helmet, and the visor is mighty close to the nose, with a fairly large servo in control i dont want to hurt my friend who is cosplaying with the servo running full bolt.

Here is the code, I’ve played with where in the coding to try the speed setting (outside the begin, just under the begin, and as here above the servo position), and even tried it with out the acceleration. I had a go at trying to use the get_moving_state, but it made no difference. I tried adding delays, no help.
i have the servo speed also set in the channel settings but this makes no difference when un-plugged.

Channel 5 has a on/off button, channel 1 is my servo, and channels 3&4 are LEDS.

[code]begin
5 get_position
dup 200 less_than

if
50 1 speed
45 1 acceleration
8690 1 servo
6000 3 servo
200 4 servo

else

if
dup 200 greater_than

50 1 speed
45 1 acceleration
5696 1 servo
6972 3 servo
6000 4 servo
endif

endif
drop
repeat

[/code]

My searches on here have led me to nothing that seems to work, and the user guide doesn’t seem to have the answers either that i have found…

If it matters: i’m running the unit off a single 9V batttery powering the chip, servos and LEDS.

So if anyone has some ideas that would be amazing! :smiley: and thank you for any and all help in-advance.

Hello.

We generally do not recommend using 9V batteries for servo applications for a couple of reasons: standard hobby RC servos typically have an operating voltage range of 4.8V to 6V, and 9V batteries usually cannot supply the current required by servos. We typically recommend budgeting at least 1A per standard size servo. Could you try switching to a different power supply (preferably a 6V AA battery pack or a benchtop supply) to see if that fixes the problem? Also, note that the first servo movement after the Maestro is powered will be at full speed and full acceleration. More information about this can be found in the last question under the “FAQs” tab of the Maestro controller product pages.

-Brandon

Hi, thanks BrandonM.

The reason I’ve been using a 9V is due to room and weight in the helmet. the 9V is also powering the chip as well, with the power connected to Vin, as per the instructions in the user guide to allow use of one power source. I tried swapping it over to a 4xAA unit I had already been playing with, but it couldn’t even light the chip up on its own (let alone power the LEDs or servo). I did initially have it running off two of these 4xAA battery packs, but weight and room meant I looked into other options, and hobby shops are not overly close to me, so besides hunting one down and finding a RC battery unit, 9V was the next easy option.
And from what I could read in the user guide, was ok to plug in as it would only output 5V to the servo’s and it sounded like the excess would run the chip.

And yes, I understand the first servo jump will be at full speed, I’ve been making it run back and forth a few times to check if it was just the first jump, or how it wants to behave. but the speed doesn’t want to change even after I make it run through a few times.

I have a little bit of time, but I’m trying to get this helmet done by the weekend, last minuet I know, but for a project that’s been about a year in the making, and this is the second deadline to finish it up… (first deadline a few months back being the rest of the suit, and now for the helmet).

So should I try and find another power source? I’d been looking at ordering one when I ordered my Servos, but I struggled to find the information I needed on the RC batteries, and their matching chargers etc at the time. If i can find a hobby store with them locally, and talk to someone in person, I don’t really know what I need to power this. 6V or more? minimum amp etc?

It sounds like you might be confused about the way servos are powered. The three wires that go to the servo are for ground, power, and signal. The signal from the Maestro will be at 5V, but the power is directly connected to the Maestro power rails, so it will be whatever you are connecting to that rail. The 9V you are using is likely higher than the operating voltage range of your servo. As I suggested in my last post, a 6V battery pack (like 5 AA NiMH batteries) is a more appropriate supply. This is within the Maestro’s operating voltage range and most likely your servo’s as well. I understand you are concerned about weight; you might consider AAA batteries instead of AA. Keep in mind that AAA batteries typically have lower capacity than AA, and as a result they do not last as long between charges. I do not know the current requirements for your system, but you might find the “Understanding battery capacity: Ah is not A” post on our blog helpful for choosing a battery for your application.

If you see the same behavior after trying a different battery, could you post your Maestro settings file and a picture of your setup that shows all of your connections? You can save your Maestro settings file by choosing the “Save settings file…” option under the “File” drop down menu within the Maestro Control Center.

-Brandon

ah thank you Brandon, i think i was getting mixed up with the power supply. thank you for clearing that up :slight_smile: i’ll have a play and see what works, see how AAA and stuff go too. thank you :slight_smile: