Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Micro maestro servo not working

hi,

i ve connected the micro and power and servo but unfortuanetly servos not moving.


Hello.

Your connections look okay to me. Can you post more information about your particular servo and power supply? Also, did you ever have the servo connected with the connector backwards? If so, it might be possible that doing so damaged the servo. Do you have a way to test the servo separately from the Maestro (e.g. an RC transmitter/receiver)?

Brandon

hi

servo 4.8 - 6.0 V analog

battary i tried with 5.8 v adapter and 1.5v x 4 battery both not working

i ve 6 different servo tried all of them

Thank you for the additional information. If you try to move the servo by hand, is it holding its position (i.e. resisting movement)? What are the model numbers of the servos you are trying? Also, could you post close-up pictures of both sides of the Maestro controller?

Brandon