Micro maestro not serving servos

As subject line indicates my micro maestro can’t be asked to operate any servos. The unit is all of a week old (to me) and hasn’t worked via windows 7 control center GUI or slackware 13.1 command line UscCmd. Maestro shows up in device manager on windows and on linux as /dev/acm? (? = 0 and 1 if you’re not familiar with wildcards in bash). Scripts appear to run fine… just no motion. Servo(s) are futaba s3003’s from old R/C, only 1 is needed, but neither have worked even though both worked fine last time R/C was used (granted a couple years).
Servo power methods attempted

  1. 4 AA batteries using battery holder from affore mentioned R/C’s radio reciever.
  2. Old computer power supply feeding 12v into pololu voltage stepdown regulator D24V6ALV feeding approx 6v out to maestro’s battery pins.

Thoughts, ideas? Am I missing the obvious?
Edit before it’s suggested that it might be the problem, yes everything is plugged in correctly left to right signal-power-ground.

Not that this is relivant, but here’s the plan…

Use sharp GP2Y0D805Z0F 5cm sensor to trigger routine in script that

  1. starts 5-10 second timer.
  2. Move servo & open latch on motorcycle trunk (aka small space below passenger seat)
  3. Release passenger ejection spring (kidding of course).
  4. Return servo to latched postion when timer expires.


Could you check that the serial mode is set to “USB Dual Port”? You can find this option in the Maestro Control Center under the “Serial Settings” tab.

By the way, we typically recommend using a servo power supply that can provide about 1A of current per servo. Our D24V6ALV step-down regulator has a maximum output current of 600mA, so I would recommend using a different power supply, like the batteries you mentioned, or using a different step-down regulator.


Thanks for the response. I had tried that setting on windows, but not linux. I’ll assume it’s available on it as well and set via a config file if using command line? I’ll post back and let ya know.

To clarify, attempting to power servo(s) below 1A wouldn’t fry said servo would it?

Ok apparently 4 rechargeable AA’s weren’t up to par. Ran 5v line from power supply mentioned in first post and servos live. I now have a simple question only asked becaused I don’t recall reading a yeah or nay answer. i can test myself of course, but is following logic sound? Can’t I just power the servo via the 5v output on the maestro itself? I assume this would work fine, but only in a single servo application? As maestro’s marketed as multi servo controller that would likely be the reason it’s not suggested anywhere?

Powering servos from an under powered regulator probably would not damage the servos, but it could damage the regulator and it likely would cause your system to behave in unexpected ways.

The regulated 5V output on the Maestro is meant for powering low-current devices like sensors or microcontrollers. Its maximum output current is only 50mA, and if you are powering the board through Vin (not the USB), the Maestro uses 30mA, leaving only 20mA. This is not even close to sufficient for powering a servo.


Cheers man. Probably goes without saying but I’m a noob to these electronics.