Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Micro Maestro 6ch

Hello!

I am using the micro maestro 6 channel module for a raspberry pi project. The first time when I plugged in the USB in my laptop I was able to move the servos from the control center, but now it doesn’t work anymore. I am not doing anything differently. I also updated the firmware, but it didn’t help. What could be the problem?

Thank you!

Hello.

Just to confirm, is your computer still able to connect to the Maestro? Can you post some pictures of your setup, and explain how you are powering it? What are the LEDs are doing, and do any errors appear in the Maestro Control Center?

- Patrick

Hello!
Yes, my computer connects perfectly to the Maestro and there are no errors. The green and yellow LEDs are blinking while I am connected to the Control Center and when I exit this app the yellow Led is blinking and the green one is steady.
I am powering the Maestro trough USB from a 6000 mAh power bank or from my computer, depending on the situation (and it worked really good everytime).
This is my setup:

It looks like you might have a Raspberry Pi and a level shifter connected to your Maestro. Can you disconnect those to simplify your system for troubleshooting? Then, can you measure the voltage on the Maestro’s servo power rails to make sure your power bank is actually supplying power?

Could you also post your Maestro’s settings file? You can save your settings file from the Maestro control center under the “File” menu.

- Patrick

Hello, Patrick!

Problem solved yaay! I’ve listened to your advice and I also reinstalled the Maestro Control Center and it works perfectly now. Thank you!

-Laura

2 Likes