Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Maestro control center trouble

Hi, I’m trying to reprogram an old Maestro 6-channel USB. I bought in 2018 and program it on my mac with parallels which allowed me to run windows. It all worked.
I have now a newer mac with parallels installed with windows 10 but the Maestro control center doesn’t find my maestro 6-channel…
I tried this:
Re-install the control center,
Try all my usb ports,
Change the usb cable,
The maestro is recognized by my computer in the usb section but doesn’t show up in the maestro control center either in my usb windows section. There is one green light and a blinking orange one. Also I’m using a usb-c to usb and a usb to mini cable to connect it.
Capture d’écran 2021-11-20 à 16.35.37



Does someone think of a solution ?

Hey, I just saw that there wasn’t any drivers installed, so I manually installed them and there is a error code (10). Do you know how I could solve it ?

Hello. I am sorry you are having trouble getting the Maestro to work on your Mac.

It sounds like you used the “Add Legacy Hardware” option in the Device Manager in an attempt to get the Maestro to work. This option is only for older devices that do not support Plug and Play and I do not expect it to help.

I recommend unplugging the Maestro from your computer. After you do that, please look for any entries in the Device Manager that have Maestro in the name. These entries do not correspond to an actual Maestro, and are just non-working entries that you added using the “Add Legacy Hardware” option. To avoid any issues that these entries might cause, please right-click each entry, select “Uninstall”, and then click “OK”. Do not check the box asking you if you want to delete the driver software for the device.

Next, please plug the Maestro in to your computer via USB. Do you see any entries for the Maestro in the Device Manager? Be sure to check the “Pololu USB Devices”, “Ports (COM & LPT)”, and “Other devices” categories. What are the three LEDs on the Maestro doing?

–David

Hi,

I uninstalled the drivers, uninstalled and re-installed the maestro controller.
There is actually anything in the device manager related to pololu.
The servo is blinking like in the video attached. I also found a windows machine where everything works but i’ll be glad if find a solution.


video: https://photos.app.goo.gl/gR4dYJYr9BDxmQou5

Could you please tell me what firmware version your Maestro has?

You can determine your Maestro’s firmware version by running the Maestro Control Center on your Windows computer, connecting to the Maestro, and looking in the upper left corner next to the “Connected to” drop-down box.

–David

It is the 1.02 firmware version

I have a new M1 Macbook Pro Max. I installed Parallels with Windows 11 (arm). When I try to install Maestro Control Center it errors on both driver files and says to right-click and choose “Install.” However, this approach fails as well. I am not sure what’s getting tangled. The Windows 11, the Arm version of Windows 11, or Parallels. It would seem that talking to a USB port shouldn’t be heavy lifting. However, “C:\Program Files (x86)\Pololu\Maestro\drivers\maestro.inf” and “C:\Program Files (x86)\Pololu\Maestro\drivers\pololu_usb_to_serial.inf” will not install. The result is Controll Center runs, but it cannot see the Maestro when connected.

Is there an update to these drivers that would get this working? Control Center is the only Windows program I use and I have three full sized Astromech droids that I am trying to maintain. It would be nice not to have to carry two laptops.

Thanks,

Tim

Hey, so the only difference I found between my two computer is the legacy hardware drive thing:


mac

windows

maybe it is possible to manually install or copy these ?

Is is working under Parallels on your mac? I’d love to be able to manually install the drivers. However, my Windows chops are over a decade old.

Tim

So i looked for an alternative to parallel and i found vmware… and it works !


guess that parallel is the problem

1 Like

You can download it for free here:Mac Software free download,Download and install software for Mac : Search results for vmware
Then you’ll need a Windows iso and you’ll find it really easily on piratebay.

PS: If you find a solution for parallel i’ll be happy cause it still easier with the coherence mode.

<3

@nw101101: Your Micro Maestro has an older version of the firmware and there is an issue that generally prevents it from working with macOS 10.11 or later. I am glad you were able to get things working with VMWare. If you want to try Parallels again, I recommend using your Windows computer to upgrade the Maestro’s firmware to its latest version. Please see the “Upgrading Firmware” section of the Maestro user’s guide.

@Eebel: We have not tried Windows for ARM or updated our Maestro USB drivers to support it. I do not know if this is possible, but maybe you could install Windows for x64 on your Mac, instead of Windows for ARM.

Hmm, I’ll see if x64 will work on an M1 under Parallels.

Thanks,

Tim

I don’t see any way to run x86 windows under parallels. What are the chances of an Arm-based driver . Or even better a Mac M1 version of Control Center?

Tim

Hello, Tim.

I just made an updated version of the Maestro USB drivers which might work on Windows for ARM:

https://www.pololu.com/file/0J1854/maestro-windows-drivers-211203.zip

You can install them by downloading the ZIP file, unzipping it, and then right-clicking on both INF files and selecting “Install”. If the drivers are working and you connect a Maestro to your computer, you will see an entry for the Maestro in the “Universal Serial Bus devices” category of your Device Manager, and two entries for it in the “Ports (COM & LPT)” category. You might need to unplug the Maestro from USB and plug it back in.

After installing the drivers, you should try running the Maestro Control Center software, which is available from the Maestro user’s guide. (The download above just contains USB drivers for Windows, not any software.)

Please let me know if these drivers work for you, and let me know if you have any further questions!

–David