Maestro Control Center not starting

I purchased a Micro Maestro 6 channel USB Servo Controller (model 1351) and downloaded the “”

After unzipping this file into a folder called “maestro_windows”, I double clicked on the file “setup.exe” I found in the “maestro_windows” folder. Installation appeared to proceed as indicated in the Pololu Maestro Servo Controller User’s Guide.

I next plugged the model 1351 into my computer’s USB port using the Pololu #130 USB Cable A to Mini-B adapter cable. Again the installation appeared to proceed as indicated in the Pololu Maestro Servo Controller User’s Guide.

I next attempted to start the Maestro Control Center found at “Start” —> “All Programs” —> “pololu” —> "maestro control center"
by double clicking on it.

Nothing happened.

I checked the “Task Manager” and nothing related to “maestro control center” appears to be running in “Applications” or “Processes”

I checked the “Device Manager” and the “Pololu Micro Maestro 6-Servo Controller” appears under “Pololu USB Devices” and “Pololu Micro Maestro 6-Servo Controller Command Port (COM3)” and “Pololu Micro Maestro 6-Servo Controller TTL Port (COM4)” both appear under “Ports (COM & LPT)”

I am running Windows XP SP3 and the “usbser.sys” file is version “5.1.2600.5512” (a later version than the 5.1.2600.2930 required).

Again, Maestro Control Center is not running when I double click on it. Any thoughts?

Hello. Sorry you are having trouble with the Maestro Control Center.

Could you try running the program directly without using the shortcut? Navigate to the “bin” folder of your Maestro installation (by default that will be C:\Program Files\Pololu\Maestro\bin). Then double click on the “Pololu Maestro Control Center.exe” icon. Does anything happen then?

What happens if you open up a Command Prompt and try to run “usccmd”?


Thank you for the suggestions. Running “Pololu Maestro Control Center.exe” directly also gives no result. Nothing on the screen and nothing in “Task Manager.”

When I run “UscCmd.exe,” a command prompt window opens momentarily then closes. If I open the Command Prompt window using “start” —> “All Programs” —> “Accessories” —>“Command Prompt” and then enter the complete path to “UscCmd.exe” with the “/k” switch (to keep the window open), then I get a list of actions to select from.

You shouldn’t need to use the “/k” switch to keep the window open. But anyway, it sounds like UscCmd is running, which is good. Could you run “UscCmd --list” and “UscCmd --status” to make sure that it detect your Maestro and can talk to it?

Could you try running “Pololu Maestro Control Center.exe” at the command line? (You will need to type the quotes.) Maybe it’s printing out an error message that we can’t see.

What versions of .NET do you have installed? There is a list of all installed programs in your Control Panel somewhere, and there should be some entries in there that start with “Microsoft .NET”. Which ones do you have?

What files do you have in the Maestro bin directory? There should be these and only these: Bytecode.dll, FirmwareUpgrade.dll, InstallHelper.dll, Pololu Maestro Control Center.exe, Sequencer.dll, UsbWrapper.dll, Usc.dll, UscCmd.exe. They should all have file sizes between 11 KB and 186 KB.


Thank you for letting me know about not needing the /k.

The UscCmd.exe --list command returns "1 Maestro USB servo controller device found: #00006716"
The --status command returns a table with “0” values for (channel) #, target, speed, accel, pos. It also returns errors: 0x0000.

From the Command Prompt, executing “Pololu Maestro Control Center.exe” returns “is not recognized as an internal or external command, operable program or batch file”. I tried renaming it to PMCC.exe. This does not return the error message but also does not cause any other action.

I have the same files as you specify that were extracted from the .zip file.

If I look at “Add or Remove Programs” in the “Control Panel”, I see Microsoft .NET framework 1.1, 2.0 SP2, 3.0 SP2, and 3.5 SP1.

The Microsoft .NET Framework 3.5 SP1 is all that is required to run the Maestro Control Center and UscCmd. They should both work.

Maybe your ‘Maestro Control Center.exe’ got corrupted somehow. Could you go to our website and download a fresh copy of the Maestro software from this page?
Just extract that zip file to a temporary location and try running ‘maestro_windows\bin\Maestro Control Center.exe’ and see if you get the same result as before (there is no need to run setup.exe).

Maybe your .NET Framework 3.5 got corrupted somehow. Could you try uninstalling it and then reinstalling it? You can uninstall it from the Control Panel and you can reinstall it by downloading it from Microsoft’s website: … laylang=en and running the installer.



There is also this Automated cleanup tool to remove the .NET Framework 1.0, 1.1, 2.0, 3.0 and 3.5. I had to use that once when my .NET install got corrupted. The symptoms I had were kind of similar to yours: I couldn’t run any .msi files and certain programs would not run at all.

- Ryan

Thanks for the additional suggestions. Sorry but the fresh Maestro Control Center didn’t fix the problem and uninstalling-reinstalling Microsoft .NET 3.5 SP1 did not fix it either.

The UscCmd.exe functions although I cannot get the example servo scripts to move the servo. The LED script works. I wrote a script to blink the Red LED, move the servo and blink the Red LED. The LED blinked but the servo didn’t move. The servo status changed to the commanded parameters but mechanically, nothing happened.

For now, if I can get the servo to move, I would be happy.

Thanks for the suggestions

Did you try the automated cleanup tool?

- Ryan

How are you powering the servo? --David

I am using a 6V latern battery connected to the “bat” input (servo power pins). The minus pin aligns with the GND pins of the header (pins nearest the edge of the board). The servo is a Pololu #1057.

I did not try the Microsoft .NET cleanup utility. I am researching what it does.

Regarding the servo: The Maestro’s default serial mode is “Uart, detect baud rate” but it can’t send servo pulses when it is in that mode if it hasn’t detected a baud rate yet. If you were able to use the Maestro Control Center, it would have offered to change the serial mode to “Uart, fixed baud rate” for you. But since you are just using UscCmd, you’ll have to change the serial mode by editing your Maestro configuration file and replacing the SerialMode line with this:


(You will need to load the settings from the Maestro, edit the file, then write the settings back to the Maestro using UscCmd.)

Then after that you should be able to use the “–servo” option to move your servo.

Let me know if you have problems doing this.


That did the trick, my servo script is now moving the servo!

Thank you very much!