Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

LSM6DS33 not responding

Hello. I’m trying to operate the Altimu 10 V5. I’ve been able to get data from the barometer and magnetometer, but no luck from the accelerometer/gyroscope(LSM6DS33). I’ve been tried the provided libraries and a couple things by hand using the datasheets, but the program just freezes after the “imu.read();” command. This goes across an arduino uno(5V), nano(5V) and pro mini(3.3v). I’ve gotten one of the boards working before, but it had a rapid unscheduled disassembly in a high power rocketry accident. Any advice on how to get it working, or if you think it’s just a dud?

Hello.

I am sorry you are having trouble using the LSM6 on your AltIMU. Were you ever able to get data from that sensor (i.e. before your rocket incident)? Can you post pictures that clearly show your AltIMU and the connections to it? How are you supplying power to the AltIMU? If you have not already, can you try running the Serial sketch from our Arduino library for the LSM6 without any modifications? If you have tried this, can you confirm that you ran that sketch without modifying it? Also, you mention you had “one of the boards working before”; are you referring to your Arduino boards or the AltIMU?

-Jon

  1. I was able to get data off the sensor on an Altimu 10 v5 I bought previously, which is in pieces now. I can get data off the other 2 sensors on the current board.
  2. I can post pictures soon.
  3. Via a 3.3v linear regulator to the VCC pin.
  4. I tried the default sketch. It did not work.
  5. I am referring to the AltiMu

How are you using your current partially-working AltIMU (e.g. have you used it in a potentially hazardous situation, like being launched in a rocket like your other AltIMU)? Which type of Arduino are you currently working with? Is the Arduino setup you are currently working with identical to the one you used to successfully read the LSM6 on your other, destroyed, AltIMU? If not, can you describe the differences (using a schematic would help)? Additionally, can you link to the product page or a datasheet for the 3.3V regulator you are using? It would be good to see those pictures you are working on getting, too.

-Jon