LSM303D Accelerometer stuck at 24539


I’m having trouble with the LSM303D carrier board. I’ve designed a PCB with an ATMega328P running at 8MHz, with the Arduino bootloader (I use board type “Lilypad Arduino”), and soldered on only enough components to test the LSM303D . I’m using an FTDI cable to connect the board to my computer.

I was trying to use the Heading example program to get a heading readout when I rotated the board around the X axis (as printed on the board). After calibration I did see what looked like valid heading data but I wasn’t getting the results I expected when I had the vector set to {0,0,1}.

Using the Serial example program In the troubleshooting process I’ve discovered that the accelerometer output is stuck at 24539 on all three axes. I saw the FAQ about the brownout problem and I’ve tried leaving the board unplugged for several minutes and then plugging it back in, but that didn’t help.

I’m not sure what else to try now. Does anyone have any ideas?

Thanks in advance.


I am sorry you are having trouble reading your accelerometer. I am glad you found the FAQ that address that behavior; have you tried adding a bleeder resistor to discharge the 3.3V line more quickly?