LSM303D accelerometer offset


My LSM303D is having an offset (about -2.8 g) in x. The accelerometer has returned valid values until now. Has someone encountered anything similar? What could be the cause?

Is it possible to re-calibrate the LSM303D using its features? I could do some compensation after reading the data, but wonder if the LSM303D could be “reset” somehow. I found a “Reboot memory content” in the data sheet, I don’t know if it would help me.

I have attached a figure of the sensor readings, while the sensor is sitting flat on table (note the correct readings in y and z).

The LSM303D is integrated on the AltIMU-10 v4.

Thanks in advance!


I am sorry you are getting that offset with your accelerometer. We have not really seen that kind of thing develop in a working accelerometer before and do not have any experience with the “Reboot memory content” bit. However, we can try looking into a few things. Can you tell me a little more about your setup? How are you supplying power? If you are using an Arduino and not already running our Serial sketch, can you run it and see if the behavior is any different? Also, just to check: did anything in your system change in between when the LSM303D was not having an offset and when it started having that offset?


Hi Jon!

Thanks for the fast reply!

I’m reading over i2c using a raspberry pi. I reverted back to an older code base which I know worked, still the same issue. I tried to estimate the offset which worked well. However the offset will cause the acceleration in x to be limited (using 4 g range). I have attached some figures.

I will order a new board and hopefully it will work. Would you recommend v5? I compared it to v4 but didn’t see any greater figures for the LSM6DS33 (checked the Mechanical characteristics).

I am glad that manually removing the offset seems to help. You are right, the LSM6DS33 accelerometer on the AltIMU-10 v5 and the LSM303 accelerometer on the AltIMU-10 v4 have similar (and sometimes identical) specifications, so you are probably not missing out on much getting another unit of the older v4 version.