Losing USB Connection to the Maestro 24 Board

Every year my dad and my brother are building an automated ball path for the advent season displayed in the shop window of our mothers sewing shop. (The project of last year: vimeo.com/84050157)
Since last year we are using some servos on different occasions and of course the Maestro 24 USB Servo Controller. I would like to thank you for the great device at an unbelievable price with a satisfying API!

Now, I run into following problem:
From time to time I’m losing the connection to the Maestro board and need to plug off / on the device to get the connection back. It is not reproducible and even not dependent on a servo movement. The time when my application starts up to the time when the connection is lost varies from 1-10min approximately.
Sometimes the green LED is still on, usually it’s still on. The yellow LED behaves still like the board is connected and the RED one … I’ve never seen the RED one on.

Last year - the system is just running from dec 1. 'til jan 6. - we could resolve the problem using a shorter USB cable. Since we tried to use the same cable this year - ok, we tried several cables without any improvement - we don’t know how to get rid of the problem.

[ul]CPU Power: USB[/ul]
[ul]Blue Jumper: Off[/ul]
[ul]Servo Power: External 5V[/ul]
[ul]Servos in use: 2[/ul]
[ul]USB cable length: 30cm[/ul]
[ul]Language: Visual C# (Connection with given USBWrapper / USC API)[/ul]

Since we are using several 12V motors, a step motor, a SPS, etc. I know there could be any disturbance from other devices. But the system power is separated from the other devices and the servos are really precise controlled … when they are working …
If the connection is lost, I get an exception in the software, the servos can be moved by hand - -> there is no signal from the Maestro board - and even the Maestro Control Center is not able to find the Maestro board before I plug it off and on again.

I hope, I didn’t forget to write any information to resolve the problem quickly.


Since your Maestro loses connection after anywhere between 1 and 10 minutes, I agree that it could be a noise problem like you mentioned. You might try using a USB cable with a ferrite bead at one or both ends (preferably the latter). You might also try using a powered USB hub between the computer and the Maestro.

By the way, all of us here enjoyed your video! We found it very entertaining, and fun, and we made a community project blog post about it. Thank you for sharing it.