Pololu Robotics & Electronics
My account Comments or questions? About Pololu Contact Ordering information Distributors

Locosys LS20031 GPS - no fix


Greetings, was hoping I might beg to query the uber gurus here. :slight_smile:

I just got an LS20031 GPS (unfortunately I didn’t get it from Pololu; I wished I had since I’m still trying to get the vendor to respond to my queries :angry: )

I carefully connected it to my mbed mcu per the GPS datasheet, checking Vcc prior to hooking up to ensure 3.3V etc.

As expected, I am getting output at 57600 baud, no problem, timestamp incrementing by 200ms and everything:


The problem lies in the fact that the GPS never gets a fix, red LED never blinks at 1Hz per datasheet. The LED blinks once on powerup, then never again.

Have tried outside, inside, near windows, etc. I’ve given it 10-30 minutes to get a fix (I thought it has a 35 seconds TFF… not minutes or hours :D)

I wonder if I got a defective unit or am I missing something obvious once again? :slight_smile:

Using MiniGPS, I’ve successfully sent control commands ($PMTK…*) to the receiver to change update rate, etc., and that seems to work fine, too. I’ve commanded it to do a cold start and it just times out.

So … what would prevent it from getting a fix while the ‘brains’ behind the module work a-ok?

Any other ideas?

Thanks in advance! :slight_smile:




Did it ever work for you? I’ve seen this thread about people having trouble with the GPS lock on their GPS modules after having crashed the flying vehicles they were in. I would not recommend soldering it unless it looks obviously disconnected or poorly connected and you feel confident in your soldering skills.

- Ryan


Thanks for the quick response!

The GPS never worked, new out of the box. :frowning: Will inspect the can and see if that is the issue. I’m trying again to get a gps fix with the metal can clipped to gnd… I dunno…