Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Linux IDE programming issue


#1

Trying to replace a previously loaded Linux program that was done via the ISP on an A STAR prime. The USB based IDE via the computer won’t work. First of all, it defaults to the avrdude program SW, which was previously only used for the ISP load using an external programmer. It won’t accept any port (ttyACM0 or ttyS0). Changing/verifying port permissions doesn’t help. Same symptoms regardless of whether I’m using a new sketch or an example, such as blink. Any auggestions appreciated.


#2

Hello.

What “USB based IDE” and ISP programmer are you using? Can you provide links to them?

Also, can you clarify what exactly is the issue you are having or what you expect to see (e.g. computer does not recognize device)? If you get any error messages, can you post screenshots of them? It would be helpful if you can post pictures of your setup clearly showing all of your connections.

- Amanda


#3

This turned out to be a Linux permissions issue; here’s what worked for me (Ubuntu 18.04):

  1. Created a rules file for the ACM0 device and placed it in the /etc/udev/rules.d directory, in order to allow correct permissions at boot.
  2. Rebooted, started the IDE and connected the A STAR, then burned the bootloader in order to override the previously-installed sketch which had been loaded using the external programmer.
  3. Rebooted again, started the IDE, connected the A STAR and uploaded my sketch, which worked, including the serial monitor.