Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Launch has failed and Studio could not read Target voltage


#1

Hey,
So I am trying to program my baby orangutan and I get the following error when trying to do so.

I have checked the ribbon cable and it is correctly orientated.

This is the device programming screen

I’m fairly sure that the problem is something to do with the 4.6 volt part.
However using the multimeter I get

VIN - GND = 9.48V
VCC - GND = 5V

So I know that it is not under powered, however Atmel studio seems to think it is.

Here is the setup

Thanks in advance for any help


#2

Hello.

I am sorry you are having problems programming your Baby Orangutan. Can you try to program the Baby Orangutan by clicking on “Device Programming” in the “Tools” menu. Then, you will need to click on “Apply” to select the programming and device options. Lastly, click on “Memories” and the “Program” button.

If that does not work, can you try a different USB cable?

-Derrill


#3

Ok so I got a new cable and tried doing the thing that you said.

and got the following error:


#4

Can you try adjusting your ISP Clock frequency to about 460.8 kHz. You can adjust it in the “Device Programming” menu under “Interface Settings” as seen in the second picture of your first post.

-Derrill


#5

Hi,

I had the same issue and i did what Derrill said and it worked, but now I always need to do the same,

Tools -> Device Programming -> select STK500 -> apply -> Interface Setings -> ISP clock at 460.8 kHz ->Set -> Memories and Program

because if I want to build just with F5 the same error shows and after the error shows I try to program the BabyO following the long procedure but it seems like the STK500 is busy

and i need to close and reopen atmel studio 6.2 in order to program the BabyO with the long procedure.

Does anyone know why this happens?

  • Daniel

#6

Hello, Daniel.

Can you take a screenshot of your project’s Tool setting and post it here? (If you are not sure how to do that, click “Project”->"[project name] Properties…" and select the “Tool” tab.)

- Amanda