L3G4200D 3-Axis Gyro + WIXEL

Hi everybody,

I am trying to established a i2c communication between my Wixel and a L3G4200D 3-Axis Gyro, I have connected the clock and the data line. I am using the serial_i2c app from the package (in usb mode). I have tried to send some commands to my device through a terminal but it does not seem to work.

Is it possible to do that ? Is there another way to get my angular velocities ?

Thank you,


Hello, Martin.

You should be able to use a Wixel to communicate with the gyro over I2C.

Are you using the Serial to I2C app described in the Wixel user’s guide? Have you changed any of the app’s configuration parameters? Can you describe all of your connections you have made? For example, how are you powering the gyro? And, do you have a ground connection between the Wixel and the L3G4200D? An in-focus picture of your setup and all your connections might help us notice something.

What terminal program are you using to send commands? What commands are you sending? What baud rate are you sending them at? What result are you expecting? What result are you getting?

- Ryan

Hello Ryan,

Yes I’m using the Serial to I2C app described in the Wixel User’s Guide. I have tried different parameters, you can see my last config in the picture.

My parameters for the app are :
bridge_mode : 2
baud_rate : 9600
IC_SCL_pin : 2
IC_SDA_pin : 3
cmd_timeout_ms : 0

(The other parameters are inchanged)

I have tried to send my commands with HyperTerminal, Advanced Serial Port Terminal, … (Do you have a program to recommand ?) (baud rate : 9600)

I sent these commands (same as in the Wixel User’s Guide) :

‘S’, 0xEE, 2, 0xF4, 0x2E, ‘P’
‘S’, 0xEE, 1, 0xF6, ‘S’, 0xEF, 2, ‘P’

I get nothing back, except some “ÿ” or “…” !

I am expecting some informations about my gyro (X,Y,Z velocities or variations)

Do I have to use some pull-up or pull-down resistors ?

Thank you.


I see a couple of problems. In the picture, it looks like you have SCL and SDA on Pins 1 and 2 not 2 and 3 like you have configured. Can you check that? Also, the command examples in the Wixel user’s guide are not for the L3G4200D, so they will most likely not work. For example, I do not think 0xEE is the device address of the L3G4200D. You will need to look at the L3G4200D datasheet to learn about the protocol, or try to port our Arduino library to Wixel commands.

- Ryan