Killed my Orangutan...again

I’m trying to figure out if anything can be done for my poor abused Orangutan. This is the original mega8 board that Jan rescued with a mega168 transplant after I unsuccessfully tried the same chip-swap (aka Frankenstein’s Orangutan).

I was going to load up some old code, so I tried to switch the clock fuse from the external crystal (I have a 20MHz crystal on it) back to the internal 8MHz oscillator. I just upgraded to AVR Studio 4.14, and the programming menu is way different (worse if you ask me!). It seems to have automatically configured itself to program a mega8, since the project file I loaded was originally written for one, and it didn’t give me the usual “Signature does not match selected device” warning. There isn’t any code on the chip for me to check if it’s executing or not, but since I changed that fuse I haven’t been able to enter programming mode. I have tried every AVRISP mkII frequency setting with no luck.

I’m not sure what fuse I actually programmed, but I figured with an external crystal all my bases were covered (unless I somehow managed to program the external reset disable fuse). Or should I try swapping out my 20MHz crystal for a slower one? Anyone have other ideas?

If all else fails, it might be time for me to try my hand at MLF package soldering again…


Hi, Adam.

One thing I can suggest is trying to deduce which fuse you programmed by looking at what the mega8 fuse bytes would have been for the clock settings you selected. If you compare these to the mega168 fuses, you should at least be able to figure out what you changed. This might be able to help you figure out what steps to take to fix the problem.

- Ben

I had been trying to figure that out. From the datasheets I wasn’t sure I could assume that the two fuse bytes of the mega8 are in the same place as the two lower fuse bytes of the mega168, but It turns out that they are. I accidentally programmed the Orangutan to operate off of an external low-frequency crystal (i.e. a watch crystal), so no wonder it couldn’t keep up with the 20MHz one I had on there! I found an old watch crystal around my lab, made the swap, and I’m back in business.


1 Like