Issues with U3V50ALV

Hey from the UK! I just received the U3V50ALV board and tried adjusting its output from Adafruit powerboost 5v lipo board, it worked! but then when trying to adjust it again and the voltage started lagging then it started dropping down to just below Vin and now it won’t move even when driving it from my bench supply at 5v.

I am sure I can get it replaced from my supplier but I was just wondering if there is anything I can check? I tired measuring the potentiometer as perhaps it could have failed but seems to check out


It is possible you damaged your regulator by continuously turning the potentiometer and setting a VOUT that was lower than your VIN, which we warn about on our product page:

There are a few things we can do to try to check though. Can you post pictures of your testing setup that show all the connections you were making when the regulator stopped working? Can you also post closeups of the board so I can look for signs of damage? Lastly, can you remove any load from the output of the regulator and measure the voltage you are seeing on the output terminals?