Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Issue with Zumo32U4 LCD display

Hi, I am new to this forum but I have encountered a weird issue with the Zumo32U4 robots that I have been working on as part of a college project.
I am trying to get six Sharp GP2Y0A51SK0F Analog Distance Sensors (2-15cm) connected to the robot so that it can make its way through a maze with a good amount of coverage as far as detecting the walls around it is concerned. I worked with my professor a little as to how we would go about this, and he ended up wanting me to connect capacitors to the sensors somehow, and what we ended up doing was soldering the capacitors on to the power and ground wires of the connectors used to plug the sensors in.
The capacitors we are using are 10 micro-farad, 16v electrolytic capacitors, so I connected the leads of the capacitors to the corresponding wires, with one capacitor for each sensor connection. At this point, I have done all six capacitors for one robot, and I started the same procedure for the second robot, but after soldering the first capacitor, my LCD issue came up on the second robot (I had already noticed the problem on the first robot by this point, so this is how I was able to confirm that it is likely something to do with the capacitors).
What ends up happening is the LCD’s have gone from displaying actual text, to now only showing rows of blocks across the screen. And the motor/wheel test function that the robots seem to have had programmed into them no longer work (I do not know if they were prepackaged this way or if someone working on this before me had programmed them with that function).
Otherwise, everything else still seems to work okay after this happens, the sensors read distance as expected when tested with the Arduino IDE serial monitor and everything still powers on, but I am wondering if this is an issue that someone else has had before, or if it is something that can be fixed. I have made sure that none of the pins the analog sensors are connected to conflict with anything else, but I after looking into it a little bit I am becoming afraid that six analog sensors may be more than these robots are realistically able to handle. Any advice is appreciated!

Hi.

Which analog inputs on the Zumo 32U4 are you connecting the sensor to? Did the sensors work with the LCD before soldering the capacitors or have you tried testing one sensor at a time? All our example programs for the Zumo 32U4 can be found on our library GitHub page, but none of them read analog sensors like those Sharp GP2Y0A51SK0F sensors, so your code was probably written by someone there.

-Claire

I did test at least on the first robot that all of the sensors worked individually prior to having the capacitors soldered on, as well as the LCD (as I implied in my original post, I made sure to check the LCD pre-capacitor just in case), and everything seemed to work before soldering the capacitors. So this is where I am led to believe that the capacitors are part of the issue some how. I would have to double check with my professor to see where he got the original code that we used and edited for our purposes from, so that will be something that I ask him this week.


The analog inputs that I have the sensors on both robots using are:

  • A0
  • A2
  • A6
  • A4
  • A11
  • A3

I did my best to make sure that none of the analog inputs that I connected the sensors to would conflict with any of the other components of the robots, but I am concerned that I may have failed in that regard via some oversight with the pins I ended up using.

**Sorry for the delayed response, it’s been a busy few days
***Edit; I am not sure why the font is so big for the beginning chunk of my post. I can’t seem to find a way to change it…

Could you use an oscilloscope to look at the voltage on the 5V node of both Zumos? If you don’t have an oscilloscope, a multimeter might show something. Could you also post pictures that show both of your Zumos and how the sensors and capacitors are connected?

-Claire

I will have a few images attached to show the wiring situation. The Zumo that has all the capacitors and sensors attached and mounted on the white shell in one of the pictures was the first one. I have all of the capacitors wrapped in heat shrink to keep them isolated from each other.
For the second Zumo (The one without any of the sensors or capacitors attached), I have a picture showing what the LCD output looks like after attempting to solder a capacitor on, as well as the points on the wire that I made for the capacitor (this is the setup that I went with for all 6 capacitors on the first bot).
The third image that I posted is of the connector used to plug the sensors in, just for reference.

When testing the 5V nodes on both Zumos with a multimeter, the readings came out consistently between 05.08V DC and 0.5.13V DC (I hope I understood correctly what reading you were wanting).

**I had to put the pictures in a folder and share them through Google Drive, as they seem to be too large to simply upload here. Sorry for the inconvenience.
https://drive.google.com/drive/folders/1NpIfWpGpFDcxkVUvbDLJk7wgcOFvqhUK?usp=sharing

What program is currently loaded on the Zumos? If you are not sure your current program uses the LCD, can you try our LCD Basics example? Black rectangles like that is what we would expect to see if the Zumo’s code doesn’t use the LCD.

To help narrow down where the problem is, do you have access to any other Zumos with working LCDs that you might be able to try swapping around? (Note that you should avoid plugging and unplugging the LCD while the Zumo is powered.)

-Claire

Unfortunately we do not have access to any other Zumos that I am aware of. The code issue that you proposed sounds plausible, though. I will give that a look over the weekend. Thank you.