Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Issue with VNH5019 Motor Driver

Hello all. For context, I am a MechE student whose trying to become more proficient with electronics over the summer and I decided to build an RC car using Pololu’s VNH5019 motor driver (https://www.pololu.com/product/2507), an Arduino Uno, two 12V DC motors (https://www.pololu.com/product/4741/specs), and an HC-05 bluetooth module. I am powering the Arduino and the motor shield separately. More specifically, I’m using a 9V battery for my Arduino and 8 AA batteries to power my motor driver. The bluetooth module is connected to an app on my phone, which should allow me to control the motors. However, whenever everything is connected, no voltage seems to go to the motors.

I’ve scoured the internet for reasons as to why this is happening and I believe there are seem to be two, common causes for this. One, lack of common ground (which I fixed but still no response from the motors). And two, not enough current being drawn from the batteries. I suspect the latter is the cause since I’m using alkaline batteries. If this were the problem, I would need to buy new batteries but I would rather not. Thus, I would like to double check with the community to see what they think: Do you think my AA alkaline batteries are at fault and should I get new ones (i.e. Li ion batteries)?

Also, do I need to supply the motor driver with enough voltage for both it and the motors to run? Or is it just enough to provide it the 12V needed for the motors to run since that’s within the motor driver’s voltage-range as well.

Hello.

The driver you use should be selected based on your supply voltage and motor, but generally the power requirements for the driver itself will be insignificant compared to the motor. While alkaline AA batteries may not be the best choice (they might not be able to supply enough current without the voltage dropping or last very long depending on your load) I think you should be able to at least test your dual VNH5019 and motors with no load as long as they are charged.

Can you post some pictures of your setup so I can check for other possible issues? Are you using our library, and have you tried running our example program from it?

By the way, if you are using your board as a Arduino shield, then it should always have a common ground connection with your Arduino without needing to add anything (as long as all your connections are soldered and everything is attached correctly). However, if you ever tested it as a general-purpose motor driver (i.e. not installed as a shield) without a common ground, that might have damaged it. But, I still think it is worth doing some troubleshooting to learn more.

- Patrick






Above I have attached some pics of my circuit along with a schematic. Hopefully they help.

As for the code, I double-checked and made sure all the necessary libraries are installed and that everything uploaded to the Arduino properly. Tried running the demo code from the Github but still produced no response from the motors and the voltage provided to the motor pins seemed to stay at zero. Double-checked my Arduino and bluetooth module recently and made sure they’re working too so pretty sure the issue lies in the motor driver.

And as for the shield use, is there still a common ground between the Arduino and the driver if I use the VNH5019 as a shield without the optional, blue, two-pin jumper between it and the Arduino?

Another note, I think there is a chance it is the soldering. I was testing the circuit to make sure it worked before I finished soldering the motor shield so that’s why I had not done so yet. I will try fixing that and get back to you. Thank you for the quick response!

Even without the jumper attached, there will be a common ground connection between your shield and Arduino. However, you absolutely will need to solder the header pins to make good electrical connections. Simply inserting the headers through the board will not ensure reliable contact, and intermittent connections could result in voltage spikes that damage the drivers. Once you have soldered your headers and terminal blocks, can you post some pictures showing your soldering so we can check that it looks okay?

- Patrick

Hey, sorry for not getting back to you for a bit – I needed new solder and was waiting for it to come in. Came in today and finished soldering the motor shield and it works! Both the provided demo code and the code I was trying to run worked – realized while I was soldering it that I had misplugged the terminal blocks into the shield. Put into the large holes and soldered and that did the trick (in hindsight I see why it was foolish to do this w/o soldering). Thanks for the help with troubleshooting! Let me know if you want pics of the finished circuit still, decided not to post since it worked.