"isp mode error" with usb avr programmer

i’m supposed to program an Atmega328p on an Arduino Duemilanove with “pololu usb avr programmer”. it’s my first time using avr studio.

-i’m using avr studio 4.18 with sp3
-isp cable and all connections are checked and ok
-when i try to “read signature” or “erase device” i get “isp mode error” on avr studio, and i get this on pololu usb avr programmer configuration utility:
“The SPI command for entering programming mode was sent, but the expected response from the target was not received. Make sure that the ISP frequency setting is less than 1/4th of the target’s clock frequency.”
-yellow led blinks till trying to read signature or erase device or program etc.
-after the attempt red led is solid and yellow keeps blinking

-i tried all of the isp frequencies
-in my first attempt, i managed to program my atmega328p, since then i keep getting same error.

i saw similar problems with avr programmer in this forum and want to specify that i get same with arduino duemilanove.
any help would be great.

thanks, gürkan

How are you powering the Arduino, and what voltages does the programmer list under “Measurements from last programming” in the configuration utility after an unsuccessful programming attempt?

Do you have anything else connected to the Arduino or programmer?