Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Is my voltage regulator dead?

Hello,

I am using a 12V, 1A Pololu Step-Down Voltage Regulator D24V10F12 with my 6S drone to step-down the voltage for the DJI Air Unit. It worked well for about an hour but now appears to be dead. I have measured ~24v in as expected but now 0v out.

It worked long enough for me to update firmware of the Air Unit/goggles and link it to the goggles. I flew it about a foot up and landed softly as a test flight, but upon landing I lost VTX. That’s when I noticed the Air Unit had lost power.

I’ve checked the connections and they are all good. Flight Controller to the regulator reads 24v (on both FC out and regulator voltage in). Even if there was a connection issue with the output wire I would still expect a voltage reading from the voltage out pin (yes?), however it reads 0v.

Is my board toast (I’ve ordered some more anyways), and is there some trouble shooting I can do? I’m new to this so thanks for your understanding and advice!

Cheers!

Hello.

Can you post some pictures that show the board, its solder connections, and how it is mounted on your drone? Is there anything besides the DJI Air Unit that is being powered from the regulator?

- Patrick

Nothing else is powering the board EDIT: Only the DJI Air Unit is powered by the Regulator. All connections look good, although I’m new to this so who knows.

Thank you for your response!

I am not sure what you mean by “Nothing else is powering the board”. Which board are you talking about? Can you clarify how everything on your drone is being powered (maybe by drawing a power schematic)?

Also, do you know what the material is that your regulator is mounted on? What you are using between the regulator and the plate to hold them together? I am concerned that might be causing, or could have caused, something to short and damage the regulator.

- Patrick

Apologies for the confusion! I meant to say nothing else is being powered by the regulator.

Please excuse the crude diagram. Everything on the drone works perfectly (ESC’s, motor, TX). The regulator is actually mounted on this https://www.getfpv.com/ummagrip-lite-universal-sticky-pad-blue.html, which is essentially thick 3M double sided tape (1.5mm). I was cautious to ensure that the regulator’s connections were covered by the tape too to ensure no chance of contact.

image

Your setup seems okay, so it is starting to appear more certain that your regulator was somehow damaged when you landed. To make absolutely sure that it is your regulator that is damaged and not something weird going on with your setup, could you try removing your regulator completely from your setup (including taking the tape off of it since I am not sure what its conductivity is) and test it without anything connected to the output. While you are at it, you might also try touching up your soldering (if one of the joints was not connected well, it could have been loosened with the impact of touchdown).

- Patrick

Thanks Patrick, I’ll try this afternoon. I have 2 other regulators arriving today so I’ll be swapping out for one of those regardless. I’ll check some things then. Thank you!

Hi Patrick,

So this is really strange and I don’t know what’s going on. I soldered a brand new regulator to the drone (same model) and the air unit turned on, yay. So I took it out to fly, flew it for about a minute and then landed ever so gently, and then the air unit AGAIN lost power for good. The brand new regulator is now showing 0v out. So it looks like this one is fried too. This time I made sure there was electrical tape stopping the regulator from touching anything.

Im at a loss as to what’s going on.

Cheers

It definitely appears that the regulator failures are linked to something that happens when your drone lands. It seems like there might be a power spike, so you could try adding a large electrolytic capacitor (one rated for at least 50V) across your regulator’s input in case something like that is happening.

Also, it looks like there is no direct ground connection between your regulator and the DJI Air Unit; it would be good to add one. I do not think this would have damaged it, but having a direct ground connection there would likely reduce noise and instability.

You might also consider searching around some drone forums to see if anyone else might have experienced similar issues and found a solution. If you discover something that you think might be the cause of your regulators being damaged, I would be interested to hear about it!

- Patrick

Thanks Patrick,

I tried a 3rd band new one and it immediately failed in the same way, all good until I disarm after the first flight then dead.

I have 2 new regulators arriving today, they are still 12v step down regulators but are 2.2 amp instead of 1 amp. they come with an additional ground connection point so I will run the air unit ground back to the regulator.

I have some capacitors - electrolytic polarised 63v 1uf.

I’ll try again when I’m home and let you know.

Cheers

Hi Patrick,

Adding a capacitor seems to have resolved the issue! I’ll be able to do some proper flights and testing later later today, but so far so good!

If it blows I’ll grab like a 100uf one.

With drones it seems like the motors send a surge of power when you disarm.

2 Likes