Installing A-Star Mini on Windows 8.1


I installed my A-Star Mini and Arduino IDE 1.6.3 on a Mac without any trouble. Now I’m trying to do the same on a PC running Windows 8.1, but when I plug in the A*, Windows is telling me the “USB device not recognized” message. I have installed the a-star driver and Windows told me “The operation completed successfully”. I am logged on as administrator.

Any idea what I should do to get it going?


Hello, Daryl.

I am sorry you are having trouble programming your A-Star Mini. Can you post a screenshot of your Device Manager with the Pololu USB Devices and the Ports (COM & LPT) tabs expanded? I suspect you might not have installed the A-Star drivers properly, which most likely is the reason the bootloader is not being recognized. You should follow the instructions in the “Installing Windows drivers” section of the A-Star 32u4 User’s Guide to make sure the drivers are installed.

- Amanda

Hi Amanda. I believe I followed the instructions in the user guide. The A-Star was found on COM7. I was able to load the Blinky example once, but the upload failed on a second attempt a few minutes later. A screen grab is attached. As you can see, the COM port disappeared.

I am not sure if you are actually using an example called “Blinky” or if you misspelled “Blink”. If you are using a sketch called “Blinky”, can you post a copy of the code here? What board did you have selected in the Boards menu of the Arduino IDE when you successfully uploaded the sketch? What board did you select when you tried loading your sketch, but were not able to?

To get your A-Star working again, you should follow the steps in the “Reviving using the Arduino IDE” section of the A-Star User’s Guide.

- Amanda

Sorry, I was referring to the Blink example. There’s nothing wrong with the A-Star itself, because it works fine with the Arduino IDE on OS X. I can’t get it to be reliably recognised by Windows. I’ve tried several A-Stars and they all have the same problem with Windows. I tried an Arduino Uno on the same PC and it worked every time (without needing a driver to be installed).

To answer your question, the board selected is the A-Star, both when it works and when it doesn’t. The only difference between the two cases on the PC side is, when Windows doesn’t recognise the device any more, the Arduino IDE disables the port menu.

I usually use a Mac so normally I wouldn’t bother with Windows, but I was wanting to teach some students how to program the A-Star, and they all use Windows.

We mostly use Windows machines here at Pololu and have not heard of any significant problems with people using A-Stars on their Windows computers.

Can you double-click on the “Unknown USB Device” entry in your Device Manager that is suppose to be recognized as your A-Star, go to the “Details” tab, select “Hardware Ids” from the drop-down menu and post a screenshot of it here?

Also, can you try pressing the reset button twice (within 750ms), which should make the A-Star go into bootloader mode, and post a screenshot of what you see in the Device Manager for the 8 seconds while the device is in bootloader mode?

If you have not done so already, can you try using different USB cables, a different port, and a different computer, so we can narrow down what might be causing the issue?

- Amanda

I can manage to get in one or two uploads of Blink before Windows says it doesn’t recognise the A-Star.

I have tried changing cables, and ports, to no avail. This is the only Windows machine I have access to so I can’t say whether it works on another one.


It would help if you could give as many details as possible about what you are doing and seeing so we can try to figure out what is going on.

At one point, your A-Star 32U4 Mini was not recognized by your Windows computer, but the first screenshot in your last post indicates that Windows recognized the A-Star. The hardware ID “USB\VID_1FFB&PID_2300” corresponds to a sketch running on the A-Star which was compiled by the Arduino IDE with the board set to “Pololu A-Star 32U4”. What exactly changed between the time when the A-Star was not recognized and the time that it became recognized by the computer? It would be good if you could say exactly what you did during that time.

You said that the third screenshot in your last post corresponds to the time when the A-Star is in bootloader mode, but that screenshot does not show the A-Star at all. I would have expected to see the A-Star’s bootloader show up in the “Ports (COM & LPT)” list of your Device Manager if it is recognized properly, especially since you said you were able to upload the Blink sketch once or twice from Windows. Could you try pressing the reset button twice on the A-Star within 750ms and see if an entry appears in the “Ports (COM & LPT)” list? Please try that a couple times and make sure that the bootloader always appears for about 8 seconds.

In Amanda’s second post, she suggested following the instructions in the “Reviving using the Arduino IDE” section of the A-Star 32U4 User’s Guide. In particular, I recommend trying the “uploading-before-bootloader method” documented there. If your A-Star is in the state where it is not recognized by Windows, does that method succeed in getting it to a state where it is recognized?


Hi David,

What I’m observing and what I’ve tried to describe is really pretty simple. On powering up the Windows PC, and plugging in the A-Star, it’s recognised and I can upload the Blink example. I might even get in another upload before Windows decides the board is no longer recognised. I don’t know why Windows changes its mind. As I noted above, for the sake of comparison, this didn’t happen for a Uno I had on-hand, but it happened for 4 A-Stars.

The boot loader screen shot was taken while the board was in boot loader mode. I agree it doesn’t show what it should.

I appreciate your help, but I’ve run out of time on this occasion. I don’t know whether it’s my PC (a 6-month old laptop), peculiarities of Windows 8.1, or the A-Star, but based on this experience the lesson for me is (i) the A-Star is great with OS X, and (ii) if I must use Windows 8.1, I wouldn’t choose an A-Star.


I am sorry you are still having trouble with the A-Star on Windows 8.1. It sounds like when the computer isn’t recognizing the A-Stars, you have observed that power cycling the computer will temporarily fix the problem. If that is the case, it sounds like there is an issue with your computer, either in the Windows USB drivers or in the USB hardware itself.

Please let us know if you would like to keep troubleshooting or if you learn anything else about the problem.