Inconsistent Wixel communication with 3pi robots


The thread you originally posted this is a discussion of low-level packet success rates for the radio, and is unlikely to be related to your problem. The Wireless Serial app we provide uses a radio protocol that has acknowledgment packets and the ability to handle packet loss.

I am sorry you are having trouble with your system. Thank you for providing the video. Unfortunately, I don’t know what is causing your problem.

To narrow down the source of your problem, I recommend that you only use the precompiled Wireless Serial App v1.3, downloaded from the Wixel User’s Guide, and simplify your system as much as possible. Right now you have an iPhone that is presumably talking to a computer somehow, and the computer is sending serial commands to a Wixel, and the Wixel is controlling the 3pi. As a first step, I would turn off all the computer and iPhone software and just try using something really basic like the Pololu serial transmitter for windows to send bytes to the usb-connected Wixel. If you’re not using Windows, a really simple program that just sends some bytes to the serial port would be fine. You should post the entire code here.

You could also try simplifying the commands: does the problem still happen if you just try to turn the left motor on and off and leave the right motor alone? Do you have an oscilloscope available?

The parity and stop bits settings should not matter. The baud rate of the 3pi-connected Wixel needs to be the same as the baud rate that the 3pi serial slave program uses; this is configured using the Wixel Configuration Utility.