Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

I screwed up want to uninstall A-STAR 32u4 Mini LV

So I screwed up a driver install. I tried to install you driver from device manager when the device was plugged in that’s my fault, but now I’d like to fix it. I can not install the driver the correct way. It says simply no device driver found to be fair the other way simply said it couldn’t find a usable driver from the folder I selected so not sure how that would mess it up?

I have tried uninstalling the device
I have tried rebooting
I have tried different USB port
if I press the reset twice it shows up as a virtual com port
then after 8 seconds back to device not found

any advice?

Hello.

I am sorry you are having trouble with your A-Star 32U4 Mini LV. I would like to better understand what you have done so far and what is happening on your computer.

What version of Windows do you have?

You said “I tried to install you driver from the device manager when device was plugged in”. With as much detail as you can remember, could you explain what you saw in the Device Manager at the time, and tell me what buttons you clicked when you tried to install the driver? What do you mean when you say “It says simply no device driver found”? What specific steps were you doing to trigger that message? What exactly do you mean by the “other way”?

It sounds like your A-Star’s bootloader is working, since that is the program that the A-Star runs for 8 seconds when you double-tap the reset button, and that program is showing up in your Device Manager as a COM port. It is possible that the sketch on your A-Star has simply been erased or replaced with something that does not provide a valid USB connection. Has this A-Star worked for you or anyone else before? Have you or anyone else uploaded any sketches onto it?

Can you try connecting your A-Star directly to a USB port of your computer? If there is a USB hub between the computer and the A-Star, that might cause trouble.

Without using the reset button, please plug the A-Star into your computer. In the Device Manager, do you see any devices that might represent the A-Star? To find those devices, please open the “View” menu and select “Devices by Connection”. Then expand the entries until you find your USB controllers and hubs. When the A-Star is running its sketch, there should be an entry for it named “USB Composite Device”, but the entry might have a different name if something is wrong. Please look carefully at all the USB devices you see in the Device Manager, and see if any of them disappear when you disconnect the A-Star from USB.

–David