How to load apps onto Wixel from Eclipse with 1 click

I just walked through the tutorial to start using my Wixels and section 10.c, step 14 says “We do not have a way of loading apps onto the Wixel that is integrated into Eclipse.”

I’m new to eclipse, but I thought, given how powerful Eclipse is supposed to be, that this should be easy to do – so I did it. This solution allows you to run a “make load_APPNAME” command and view the output in a console window without leaving Eclipse. It takes a minute to set up and uses a 2-line batch file. Setup details are in the file. Hope this is useful to anyone who didn’t figure it out already.

It may be possible to do it without the batch file, but like I said, I’m new to Eclipse. Cheers, Z
load.txt (1.2 KB)

Thanks! It worked for me, and other people will probably find this to be useful too.


Just got my Eclipse IDE setup working and saw this post. Loaded the batch file per your instructions, and it worked for me as well - wonderful!

BTW, David’s fine instructions for using the Eclipse IDE needs to be modified slightly in section 10.c “Hiding Unused Features” - the ‘Launch’ and ‘Run’ command tabs need to be present for this trick to work :wink:.



I’ve run into a potential problem with the Eclipse ‘one-click’ load batch command. When I execute


from a DOS command box, the load to the wixel takes place normally. However, when I attempt to load this same project from Eclipse using load.bat, I get the following:

make: *** No rule to make target `load_io_repeater_out’. Stop.

I have been using the ‘load.bat’ feature for some time on other apps, so I’m not sure what is going on - any ideas