How to add microcontrollers to avrdude?

i want to set fusebits of atmega48pa mcu but avrdude has option only for atmega48 variant???

The latest version of AVRDUDE (7.0) does support the ATmega48PA. Here are the lines in avrdude.conf that define it:

# ATmega48PA

part parent "m48"
    id               = "m48pa";
    desc             = "ATmega48PA";
    signature        = 0x1e 0x92 0x0a;

If you can’t install the latest version for some reason, you might try adding those lines to your avrdude.conf file. Or you could tell AVRDUDE you are using an ATmega48 and add the -F option to make it ignore the signature mismatch.


thanks for anwser, i tought i had latest version as i even tried to reinstall avrdude but i quess site i downloaded it from didn’t have latest version.
gonna look for version 7.

i have now bigger problem with avrdude…
i downloaded latest version (avrdude -v7.1-windows-x64)
tried to open .exe file to install and nothing happens.
then i tried x86, and nothing,
after that i tried version (7.0), both x64 and x86, and they wont do anything either…

i tried to uninstall old version and then open .exe file of every version i downloaded and still nothing happens,

now i dont have any avrdude installed and cant install new :frowning:

and by nothing i mean that when i open .exe file it only flashes some window for split second, so fast i cant even read what it opens.

i downloaded avrdudes from here Releases · mariusgreuel/avrdude · GitHub

i managed to get it working but, now i get this in commandpromt:
C:\Users\nokia>avrdude -P com5 -b 19200 -c arduinoisp -p m48pa -v

avrdude: Version 7.0
Copyright (c) Brian Dean,
Copyright (c) Joerg Wunsch

     System wide configuration file is "O:/lab/avrdudes/avrdude.conf"

     Using Port                    : com5
     Using Programmer              : arduinoisp
     Overriding Baud Rate          : 19200

avrdude: Error: Invalid -P value: ‘com5’
Use -P usb:bus:device
avrdude: opening programmer “arduinoisp” on port “com5” failed

avrdude done. Thank you.

lol im just bad with avrdude, everything works as it should :slight_smile: