How can I know if my altIMU-10 is fried?

I just purchased the altIMU-10 and am a first time user.
I inadvertently reversed the 5V power across Vin and GND (!).
Wondering if I’ve fried it.
Is there a test I can perform to confirm whether its still functioning properly?
Or, is there perhaps a protector on the unit that prevents damage of this nature?

serial monitor of my arduino program keeps looping through ‘void setup’ and repeatedly prints the quoted text from:
Serial.println(“AltIMU-10 AHRS & Alt”);
… without any data from the IMU.
I never had a chance to see my program working properly, so not sure if its the program or the IMU that’s at fault. Hence my questions.)


I am sorry that happened to your AltIMU. The AltIMU does not have any reverse voltage protection, so it might be damaged.

We did not write that software, so we are not very familiar with how it works. Can you try running the Serial example sketches for the gyro (L3G) and accelerometer/magnetometer (LSM303) to see if you get data then? If you have another AltIMU, you might try swapping it in your current setup and to see if that works, too.


Thanks for your quick response.
Unfortunately, I don’t have another altIMU to test.
I did try to compile L3G and LSM303. I followed the instructions from the website.
I confirmed that the libraries are in sketch>import libraries.
But no matter what I try with those examples, I get this …
Serial:4: error: ‘L3G’ does not name a type
Serial.ino: In function ‘void setup()’:
Serial:10: error: ‘gyro’ was not declared in this scope
Serial:16: error: ‘gyro’ was not declared in this scope
Serial.ino: In function ‘void loop()’:
Serial:20: error: ‘gyro’ was not declared in this scope

I’ve managed to compile the LG3 and LSM303 examples and run them.
Instructions were frustratingly incomplete.
The good news is my altIMU is now responding - so, seems I’ve not ruined it.

I am glad you figured out your problem. Thanks for letting us know how you solved it.

By the way, were the instructions incomplete in the Arduino guide you linked to or on our GitHub page? If it was our GitHub page, can you be more specific about what was confusing?


The site gave me the link to the LSM303 library zip file but no specifics about how to install.
So, I used this site: as a guide on how to install libraries.
The latter is in two parts.
First part is ‘automatic installation’. I must have gone through these steps ten times to try and install the LSM303 Arduino library. It never worked.
The second part is ‘manual installation’. I tried this several times and it still wouldn’t work.
I finally figured out on my own what the problem was.
Although I downloaded the and changed the name (to remove special characters), that’s not the library I was supposed to be installing. The library I should have been installing was the LSM303 library (which was within Perhaps this process is common sense and common knowledge to the seasoned C++ programmer. But it wasn’t to me.

I am sorry you did not find our instructions. We generally write out the steps to install our libraries under the “Getting Started” section of their GitHub pages and also inside their README.textile files, which can be found inside the master zipped folder. You can follow this link to get to the Getting Started section of the LSM303 GitHub page.


Hmm, I’m not sure if the camel software AHRS code still works now that the AltIMU v4 is out. It was made for the v3, so perhaps not. I’ll look into that . . .

A number of people reported having issues with my AHRS sketch so I’ve finally made time to look into it, and it’s now fixed. It was just a silly programming error.

Nice! Thanks for sharing that it is now fixed.