Having trouble with the RC Switch - 1210

I’m not sure what I’m doing wrong but I can’t seem to get the RC switch functioning.
I’ve connected the switch to the RC receiver as per the diagram. (black-ground, red-VRC, white-RC signal in)
The voltage across the black and red is between 4.8v to 5.1v (measured on the switch), yet the LED doesn’t indicate anything and the switch doesn’t function.
Things that I’ve tried…

  1. using 2 radio receivers/transmitters
  2. turned the receiver/s on and off to determine if lack of a signal does anything different.
  3. testing the receiver by attaching a servo to the channel that the switch was on. it works fine.
  4. tried a second 1210 RC switch, no difference.
  5. tried a different connector cable between the receiver and the switch.
  6. measured the voltage between the black and RC In (white) at the switch ( it varies between .24v to .39v depending on the position of the transmitter stick for that channel)

I’m obviously missing something pretty basic, but whatever that is, I need some help to determine. :slight_smile:
cheers, Brian

a picture may help…

Hello, Brian.

You will need to supply power to VCC somehow in order to power the RC switch. Have you applied solder to any of the pads on the back of the board? More information can be found on the Pololu RC Switch with Small Low-Side MOSFET product page.

I can’t tell if you have from the picture, but be sure to solder the header pins to the RC switch to ensure a good connection.


thanks David !!
I was missing voltage to VCC .
Great Customer Support !!