Flash Warning

I’m using a Baby-O and the USB programmer for school projects.
I use the USB programmer as an USB to serial adapter and I forgot to switch the jumper
while sending command bytes.
Since then i get this warning error each times i try to verify the device.

Reading FLASH input file… OK
Entering programming mode… OK!
Reading FLASH … OK!
WARNING: FLASH byte address 0x0000 is 0xFF (should be 0x0C)… FAILED!
Leaving programming mode… OK!

what should i do?

Have you tried programming (not just verifying) the Baby-O again since moving the jumper back to the programming position?

That error isn’t necessarily a big deal. The “Verify” command in the AVR Studio programming menu checks the Baby-O’s flash memory to see if it matches the .hex file you have loaded. That error just means that the Baby-O’s flash memory doesn’t contain the program you were trying to download to it, which it shouldn’t if you haven’t successfully downloaded it yet.


Thanks for replying so quickly

Yes i tried to programm the device and it works
But now when i use the Pololu Serial transmitter to send some bytes, i received some kind of (very long) data and it freeze my computer

Is the 2 cases related?


I would expect that these two problems are unrelated.


P.S. Do you get the same kind of error message when you try to program the Baby-O, or when verifying it after programming it? If so, make sure that you have the “Erase device before flash programming” option selected.

there is no error when i programm it and verify after.