Find library: PololuSH1106Main.h

Arduino IDE problem - Trying to upload to Original Zumo.

  1. Preferences-added string for Pololu package
    2 Under sketch added library Zumo 32U4
  2. Under tools- search for Zumo or A-star boards comes up empty
  3. Verify attempt fails for lack of correct board

Now what- where do I find Zumo boards.

I solved earlier problems finding boards. Now after including Zumo and A-Star libraries i am un able to locate: PololuSH1106Main.h I tried looking on Github and ended up back here.


If you installed the Zumo 32U4 library using the Arduino IDE’s Library Manager, then you should have been prompted to install the dependent libraries.


If you clicked “Install all” at that prompt, then PololuSH1106Main.h should have be saved in your usual Arduino libraries folder in a path like this:


If you clicked “Install ‘Zumo32U4’ only”, then you can install that library now by following the instructions on the GitHub page for the Pololu OLED library for Arduino under the “Software” header of the “Getting started” section of the readme.

By the way, the file you mentioned, PololuSH1106Main.h, is only used for controlling the OLED display on our newer Zumo 32U4 OLED Robots. You mentioned that you are trying to upload to the “Original Zumo”, so I suspect you are using one of these Zumos with an LCD. If that is correct, can you post the program you are trying to upload to your Zumo? If you upload a program that has code for the wrong display it probably will not work correctly, but our library is designed so that it should be easy to swap the code for one display to the other.

- Patrick

Thanks for your response Patrick. I have both an LCD Zuno and a new Oled Zumo.
I am using recent GitHub software. After adjusting the software for the LCD or Oled versions I downloaded to both Zumos. Both calibrated as expected. When A button punched they both played the “off to the races” music and then began spinning. My board is white foamcore with 3/4 in electrical tape. What to try next?

It sounds like you are having trouble with the LineFollower example from the Zumo 32U4 Arduino library; is that correct?

If so, then your first troubleshooting step should probably be to check that the front sensors array is installed correctly. All of the headers should be plugged into the female header on the Zumo 32U4 main board (make sure it is not offset), and the blue shorting blocks that come with the sensor array should connect pin 4 to DN4 and connect pin 20 to DN2.

If the array is installed correctly, then the next step is to try looking at the raw values from the line sensors using the LineSensorTest example program. Can you do that while your Zumo is connected by USB and post a sample of the Serial Monitor output?

- Patrick