Failing to program SVP1284

Hello all,

I just got an Orangutan SVP1284P fully assembled controller.
the demo worked just fine and I played with most of its features.
after installing winavr, avrstudio, etc. I tried to program the ledblink example.
at the stk500 in ISP mode, I keep getting “Entering programming mode…failed” for almost anything I try to do, though sometimes I manage to get an action done (rarely), but I never managed to get the programming done.
my guess is that its either a power supply issue (using wallwart transformator) or faulty processor (a stuck fuse or something).
It is my first attempt with AVR products (I’m used to MPLAB) so I’m quite clueless on how to proceed - any help would do.

best regards…

update:
I lowered the ISP freq. to 115.2 and now I am able to read the device signature and fuses once in a while, but still no luck programming.
I sometimes get this:
Getting isp parameter… SD=0x02 … OKOK
Reading FLASH input file… OK
Entering programming mode… OK!
Erasing device… FAILED!
Leaving programming mode… OK!
and sometimes this:
Getting isp parameter… SD=0x02 … OKOK
Reading FLASH input file… OK
Entering programming mode… OK!
Erasing device… OK!
Programming FLASH … FAILED!
Leaving programming mode… OK!

The whole thing is very unstable…
looking forward to hearing some advice.

thanks in advance for the help,
M.

I’m sorry that you are having problems. Have you ever successfully programmed it?

What kind of wallwart are you using? Do you have information about its specifications? Which pins are you using to power the SVP? A picture might be useful.

Have you connected anything to the SVP besides power and USB?

Which BlinkLED example are you using (please tell me exactly where you downloaded it from). If you used a BlinkLED example for the wrong processor you might have trouble.

What processor have you selected in the Main tab of the STK500 dialog box?

–David

Hello David,

Unfortunately, I never managed to program it - it’s fresh out of the box.
As for the wallwart - it’s a cheap variable voltage kind, 300mA up to 12V.
I have the assembled version of the SVP1284P - and the wallwart is connected to the screw terminals of the Vin and GND (I cut one of the extensions of the wallwart and removed the insulation, checked with multimeter for the right polarity and voltage).
Nothing is connected besides USB and the Vin, tuned to 6-12V (I tried several voltages).
the blinkLED comes from here:
pololu.com/docs/0J39/5.c - the M1284P version, and the 1284P is the processor I selected from the list.
I checked on the back of the card I got from Pololu and it says 1284, but i haven’t checked the chip itself.

the weird thing is that i can’t even read voltages, in MPLAB it gives you a good reference, but here the HW settings gives me a short error message and reads nothing.

I will try later today a more stabilized power source - a converted ATX supplier.

I will be happy to provide any information that you think needed in order to solve this annoyance,
Again - thanks for the help!

M.

When I hooked the board to a stabilized source it worked like a charm!
sorry that I bothered you all, and thanks for the help.

lesson learned - though i tried to minimize sources of failure (using a known to be working script, hooking the minimal circuit necessary, etc) I used an unreliable power source with a board I"m not familiar with, especially power consumption wise.
cheap can be the most expensive sometimes…

P.S - what is the minimal power supply spec. that is needed to run the logic smoothly?

Regards,

M.

I’m glad you got it working! I don’t see any reason why your 300 mA Wallwart would cause problems with the SVP, so maybe something is broken.

I did some current measurements on my Orangutan SVP-324, running the first screen of the demo program, with VIN set to 9.0 V and USB disconnected:

It draws about 98 mA normally.

It only draws about 33 mA when I turn off the LCD’s backlight or remove the LCD.

It draws about 150 mA while playing music (and the LCD+backlight are on).

It draws more current when I lower VIN, but it doesn’t get close to 300 mA. The highest reading I saw was 212 mA while playing music with VIN at 6.0 V.

There was no major change in current draw while programming the chip.

–David

Well, go figure, probably it wasn’t stable and interfered with programming.
Anyhow, I’m knee deep busy with new problems already (XBEE related…).

Thanks for the support and the consumption tests!
M.

Sorry to open old topic, but I have SVP-324 and I had exactly the same problem.
12V 300mA wallwart, no success. Nice stabilized 12V PSU, works like charm.
I burn just 2 hours till I got here, so it is not a big deal, but this is definitely something worth to put in manual.
Good stable PSU or batteries is the must, if you want to save a lot frustration.

Thanks desertowl for solution.
P.