Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Error when trying to start maestro control center

I’m using linux mint mate 18.3 and I get these errors when trying to open it.

laptop@laptop ~ $ ./MaestroControlCenter
WARNING: The runtime version supported by this application is unavailable.
Using default runtime: v4.0.30319

Unhandled Exception:
System.IO.FileNotFoundException: Could not load file or assembly ‘System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089’ or one of its dependencies.
File name: ‘System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089’
[ERROR] FATAL UNHANDLED EXCEPTION: System.IO.FileNotFoundException: Could not load file or assembly ‘System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089’ or one of its dependencies.
File name: ‘System.Windows.Forms, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089’

Hello.

Did you install the packages specified in README.txt from the Maestro Servo Controller Linux Software download file? If you followed the instructions in README.txt, can you try running the command in this post and see if it fixes the issue?

- Amanda

I get

laptop@laptop ~ $ sudo apt-get install libmono-system-windows-forms4.0-cil
[sudo] password for laptop:
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt-get -f install’ to correct these:
The following packages have unmet dependencies:
libjpeg8:i386 : Depends: libjpeg-turbo8:i386 (>= 1.1.90+svn722-1ubuntu6) but it is not going to be installed
libmono-system-windows-forms4.0-cil : Depends: libmono-accessibility4.0-cil (>= 1.0) but it is not going to be installed
Depends: libmono-system-data4.0-cil (>= 4.2.0) but it is not going to be installed
Depends: libmono-system-runtime-serialization-formatters-soap4.0-cil (>= 1.0) but it is not going to be installed
Depends: libmono-webbrowser4.0-cil (>= 1.0) but it is not going to be installed
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).

Have you tried running apt-get -f install?

We are not familiar with your system and have not dealt with this kind of error before. You might consider reading the documentation for your operating system or asking for further assistance on a Linux (Mint) specific forum like this one.

- Amanda