Error when programming Baby-O 328p

Hi Folks,

This is my first time using a Baby-O and the V2 programmer. It is driving me NUTS!! I’m trying to load the sample program to just blink the red user LED as a starting point. I’m using Atmel Studio 7 and will compile the solution correctly but will not download to the Baby-O. I receive the error “failed to set-up tool (no context id returned)”. I’ve set up the target to use STK500 and COM3. Can anyone offer suggestions?? I’ve attached pictures of my Configuration Utility, of the exact error and of the program.

Thanks for any input!


Hello, Isaac.

Can you run the Pololu USB AVR Programmer Configuration Utility after a failed programming attempt and post a screen shot of the utility window here? There should be a more detailed error in the programmer’s configuration utility.

Also, can you post screen shots of the “Device Programming” and “Available Tools” windows in Atmel Studio 7? The “Available Tools” window can be found under the “View” menu.

- Amanda


I am using the Baby-O B-328 and AVR v2.1 programmer for the first time. When trying to send code to the device using “F5” I receive the same error as mentioned above “Failed to set-up tool (no context id returned)”

I have been unable to find a solution to this issue on the forum.

I am running Windows 10 and Atmel Studio 7 (7.02391).
I have confirmed in the device manager that the two pololu drivers are loaded correctly.
I have checked that the correct com port is shown in the available tools.
I have checked the AVR configuration utility which appears normal.
I have tested the device programming menu and I get the message “Unable to connect to tool STK500”

The AVR programmer has a green light next to the USB and flashing yellow lights next to the 6 pin plug. The Baby-O is externally powered and has a green light.

I have tried swapping the USB cable and increasing the input voltage on the Baby-O.

Any advice to solve this issue would be greatly appreciated.


Hello, David.

Can you click on Details in the Error window and post a screenshot of it here? Please move the Error window so that we can see the inputs in the Device Programming window before taking a screenshot.

- Amanda

Thank you for the reply Amanda.
Below is the screenshot showing the details.

The “no context id returned” error sounds like it might be an internal issue with Atmel Studio. I tried reproducing your error using Atmel Studio (7.02397) and an AVR Programmer v2.1 but was unsuccessful. (I could not find your Atmel Studio version (7.02391) on the Downloads archive page on the Microchip website.) Can you try restarting your computer and try again to see if that changes anything?

- Amanda