Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Error in using VL53L0X library

I’m trying to use 3 VL53L0X sensors with my Arduino nano, I’m using the pololu VL53L0X library for this. This worked fine before, but occasionally it would get stuck trying in the .init function of the first sensor. My code is the exact same as the example code in the library. Now it’s almost constantly getting stuck on initing the first sensor, I thought there was a short somewhere in my circuit so I redid all my wiring. It worked for a bit then, but my Arduino released the Magic Smoke™ since I was drawing too much power with 3 sensors.

Subsequently I added a PSU and a voltage regulator and purchased a new Arduino nano, and it worked, for a few minutes after I took a small break I checked again and now it is getting stuck constantly in initing, I thought this was me being dumb and shorting it again somewhere, so I disconnected all the sensors and it still gets stuck in the init loop instead of saying ‘Failed to boot VL53L0X’.
Some extra info, I’m using the Arduino nano with the old bootloader, all the sensors work properly individually.

I’ll be extremely grateful for any help, I’ve been looking for so long for an answer ;-;

Hello, TheTRCG.

Could you post some pictures of your setup showing your soldering and connections? A wiring diagram of your setup would be helpful too.

Note that each VL53L0X should not draw more than a few tens of milliamps, so it seems unusual that powering three would be too much for your Arduino (from what I can tell, the 5V regulator on an official Arduino Nano should be able to provide at least a few hundred mA).

Kevin


https://components101.com/microcontrollers/arduino-nano according to this the 3.3V pet can only output 50ma and each sensor uses 23 when polling, but you’re right when you said the 5v pin can handle a few hundred milli amps, it’s very confusing. I don’t know why I got the magic smoke.

Sorry for the amateurish drawing and poor pictures, I’m a bit short on time right now but I can redo them in a bit.

Hi,

Your sensor boards are not made by us, so we cannot offer any specific advice for troubleshooting problems with them. I recommend contacting the manufacturer of your boards for help with your issue.

One thing to keep in mind is that our VL53L0X carrier board includes a voltage regulator and level shifters, so our product and library documentation is written with that in mind. If your boards do not include these features, you might need to take additional measures to use them with a 5V Arduino.

Kevin

@TheTRCG, i was facing same issue with Vl53L0X and VL53L1X.
you can find the solution of this problem on youtube there is video on youtube.
image
you just can search on youtube with “How to fix VL53L0X Error”. i just saher you screen shot of that video.