Entering Programming Mode.. FAILED!


This is the error I’m getting in AVR Studio 4

Setting mode and device parameters… OK!
Entering programming mode… FAILED!
Leaving programming mode… OK!

I’ve just soldered two Baby Orangutans up and tried to program them and receive this error on both of the boards.
I did not try to program my boards without power, but I may have tried to program them with the 6 in header around the wrong way on the first one (double checked for the second).

The error only occurs when I’m attempting to program my Baby O.
I have tried the steps in the trouble shooting programmer’s user guide. I have not tried to upgrade the USB serial programmers firmware but I have been successful before with the baby o with the current firmware version.

I’ve lowered my your programmer’s ISP frequency using the “board” tab of the AVRISP dialog and tried reading the Orangutan’s device signature without success.

I tried my programmer on Windows 7 and Windows XP operating systems but exactly the same error occurs on both OS.

I find it odd that I’ve been given two boards and I’ve soldered both of the up and neither of them work?
I have soldered the male header strips and the 2x3 pin header the same way as featured on this website fro the Baby O.

I have no wiring diagram because I’ve only got power going to the baby O measuring 5.2v with my multimeter. 4.97v coming out of the Vcc hole. no other wires are attached to any LEDs, sensors or motors. Green light turns on on baby orangutang, orange light on USB programmer blinks orange when I have it connected to the Baby O and it is powered up. Red light remains on once I’ve generated the error above.

Hoping someone can help me with my programming problem. Not sure what to try next.



Also, I never touched any of the fuse settings or lockbits. the two boards just didn’t work from the start. I eventually fried my last baby O by pulling too much current through it using some micro motors, but that’s how I know my pololu USB programmer’s firmware should be ok and I have programmed using it before. I’m not sure if it could have been corrupted?



Hello, Jay,

Please make sure to specify the exact programmer you are using, as we have both an older Orangutan USB Programmer and a newer USB AVR Programmer.

It sounds like you have the newer AVR programmer though, so you should download its configuration utility from https://www.pololu.com/catalog/product/1300/resources (contained in the ZIP archive labeled “USB AVR Programmer Windows Drivers and Software”). After you generate the error and the red LED turns on, could you run the the utility and note what it reports as the “Error From Last Programming”?

- Kevin

Pololu USB AVR Programmer Configuration Utility:

Error From Last Programming:
“The SPI command for entering programming mode was sent, but the expected response from the target was not received. Make sure that the ISP frequency setting is less than 1/4th of the target’s clock frequency.”

Cheers for helping Kevin,


And yes… My programmer is a Pololu USB AVR Programmer. It was purchased about Mid-December last year.




I’ve upgraded my USB AVR’s firmware to v1.03 successfully. The programmer behaved as expected whilst upgrading the firmware.

I can connect to the USB programmer by choosing the AVR ISP platform and then choosing Auto or COM 4 to which my programmer is listed under device manager.

A window titled “STK500 in ISP mode with ATmega328P” comes up displaying the main tab. I’m not sure how this is possible if my programmer cannot read the signature of my device?

The feedback message in the main tab says:

Detecting on ‘COM 4’…
AVRISP with V2 firmware found on COM 4
Getting revisions… HW: 0x0f, SW Major: 0x02, SW Minor: 0x0a… OK
Getting isp parameter… SD=0x00 … OK

I’m at a complete loss. I’m getting very frustrated and I’m spending hours trying new things when I think I’m just going to have to buy a new programmer or baby O. If only I knew which one was more likely at fault and why it is happening so that I know for next time…

I’m going to try programming an old ATmega88 that I have found to see if there is any improvement.


Hello, Jay,

I am sorry to hear that you are still having trouble. It is likely that the programmer itself has been damaged, given that it is failing to program two different boards. You mentioned that you had fried a Baby-O earlier; was the programmer connected to it when this happened?

You said that you already checked the orientation of the ISP cable, but to double-check one more time, you have the red wire of the cable and the pin 1 indicator on the connector aligned with the pin 1 indicator on the Baby-O, right?

- Kevin

I thought I had fried a baby o before and but i’m sure the programmer was not connected when it happened. Now that I think about it… If i ‘fried’ the board by pulling too much current through it’s motor output terminals, shouldn’t that have only affected the h-bridge chip? that is, I should still be able to talk to the micro-controller on that baby o, but i would not be able to run any motors from its motor ports? I have a feeling my USB programmer could have busted then and had me thinking that my baby o was dead?

What happened last time - I was controlling the speed of a pololu 298:1 HP micro motor with the built in pot. When the motor had almost stopped due to turning the pot to it’s limit. Then suddenly, the board seemed to reset itself and would no longer talk to my baby o. It thought the motor may have stalled and drawn lots of current but come to think of it now, don’t h-bridges work with enable switches controlled by PWM? And so a stopped motor under these circumstances doesn’t mean a stalled motor pulling high current…?

If I did have my USB programmer attached when running this program, could this have caused some damage to my USB programmer? What would have caused my baby o to reset? Can the USB programmer cause my microcontroller to reset itself if the USB programmer is playing up?

I’m going to try a different programmer if possible, but I don’t have easy access to another one.