Entering programing mode.. FAILED!

I just got my baby-o 168 the other day. I assembled it and hooked it up to a pololu usb programmer powered up the baby-o got the green light on the baby-o got the one green light on the usb programmer that said it was connected and tried to program it. AVR Studio sees the programmer but when it goes to do anything with the baby-o it cant connect. I have checked and double checked the connections and everything else I could think of but to no luck it still wont take a program. Any help?


Have you looked at the troubleshooting section of our programmer’s user’s guide? Is it possible for you to take a picture of your ISP connection on the baby orangutan and upload it to this forum?

- Ben

Ok here is a picture of everything set up and ready but still wont read anything. Also I have noted that the ISP gets quite warm near the area that the connector attaches to the board when attached to both baby o and computer. I dont know if that means anything but its there anyway.

Today we discovered a bug in the PGM02B revision firmware that will cause the ISP to draw too much current when connected to the target device. This would explain why your programmer is getting hot, and I’m hopeful it can also explain why you’re having problems programming with it. Tonight we will be releasing a firmware upgrade for the programmer that fixes this problem. I’ll post again in this thread when it’s out.

- Ben

Ok, we’ve released the firmware update. Please see section 8 of of the user’s guide for update instructions.

- Ben

Ok I tried to upgrade. Got terminal up typed in fwbootload got FWBOOTLOAD 1.2: back which is the same version that I thought I needed to upgrade to. Well I erased it anyway and reloaded the firmware from the link that was in the guide (good guide really straightforward and easy to follow) but when I got done I tried to read the signature and still no luck.

The “1.2” you saw when you typed “fwbootload” was the bootloader version, not the firmware version (given how similar the version numbers are, I understand how this can be confusing). Your firmware version was 1.1 before you performed the upgrade and it should be 1.2 now. Your programmer’s ISP header should no longer get warm when your programmer is simultaneously connected to your computer and your Baby Orangutan.

Well, with that one problem out of the way, at least now we can consider other possible causes. We test the programmers and Baby Orangutans before they ship, so my immediate suspicion is that there is a problem with the connection between the ISP header pins and the Baby Orangutan. Can you visually inspect the solder joints to check for poor connections and shorts? If nothing seems obvious, my next suggestion would be to use a multimeter to perform continuity checks between the header pins and their respective AVR pads (and check for shorts between each of the ISP pins).

- Ben

I found the problem apparently one of the pins on the ISP header was at fault. I went back and touched up my solder job and it had no problems. Guess I need to work on my soldering. Thanks for the help.

That’s great! I’m glad to hear you have everything working now.

- Ben